低危 缓冲溢出UAF内存损坏

CVE编号

CVE-2018-1000030

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-02-09
漏洞描述
Python 2.7.14易受Heap-Buffer-Overflow和Heap-Use-After-Free攻击。
2.7.14之前的Python版本也可能容易受到攻击,而且看起来Python 2.7.17和之前版本也可能容易受到攻击,但是尚未得到证实。
当多线程处理大量数据时,漏洞就在于此。在这两种情况下,基本上都会出现竞争条件。对于Heap-Buffer-Overflow,线程2正在为缓冲区创建大小,但Thread1已经写入缓冲区而不知道要写多少。因此,当处理大量数据时,使用Heap-Buffer-Overflow很容易导致内存损坏。至于Use-After-Free,Thread3-> Malloc-> Thread1-> Free's-> Thread2-Re-uses-Free'd Memory。
PSRT表示,这不是一个安全漏洞,因为攻击者必须能够运行代码,但在某些情况下,例如作为服务的功能,攻击者可能会利用此漏洞来违反信任边界,因此DWF认为这个问题应该是一个CVE。

解决建议

厂商已发布漏洞修复程序,请及时关注更新: https://bugs.python.org/issue31530


受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 python python * Up to
(including)
2.7.14
运行在以下环境
系统 debian_9 python2.7 * Up to
(excluding)
2.7.13-2+deb9u3
运行在以下环境
系统 opensuse_Leap_42.3 python2.7 * Up to
(excluding)
2.7.13-27.3.1
运行在以下环境
系统 suse_12_SP3 python2.7 * Up to
(excluding)
2.7.13-28.3.2
运行在以下环境
系统 ubuntu_14.04 python * Up to
(excluding)
2.7.6-8ubuntu0.5
运行在以下环境
系统 ubuntu_16.04 python * Up to
(excluding)
2.7.12-1ubuntu0~16.04.4
阿里云评分
2.3
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-416 释放后使用
CWE-787 跨界内存写
阿里云安全产品覆盖情况