低危 procps-ng, procps 缓冲区溢出漏洞

CVE编号

CVE-2018-1126

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-05-24 02:29:00
漏洞描述
发现了一个缺陷,即procps-ng为采用unsigned int而不是size_t参数的标准C分配器提供包装器。在这些平台不同的平台上(例如x86_64),这可能会导致整数截断,从而导致将过小的区域返回给调用方,从而可能导致溢出。此问题的唯一已知可利用的是CVE-2018-1124。
解决建议
目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:
https://gitlab.com/procps-ng/procps
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 procps-ng_project procps-ng * Up to
(excluding)
3.3.15
2
运行在以下环境
应用 schneider-electric struxureware_data_center_expert * Up to
(excluding)
7.6.0
3
运行在以下环境
系统 suse_11_SP4 procps * Up to
(excluding)
3.2.7-152.31.1
4
运行在以下环境
系统 debian_9 procps * Up to
(excluding)
2:3.3.12-3+deb9u1
5
运行在以下环境
系统 debian_8 procps * Up to
(excluding)
2:3.3.9-9+deb8u1
6
运行在以下环境
系统 debian_7 procps * Up to
(excluding)
1:3.3.3-3+deb7u1
7
运行在以下环境
系统 amazon_2 procps * Up to
(excluding)
3.3.10-17.amzn2.2
8
运行在以下环境
系统 suse_12_SP3 procps * Up to
(excluding)
3.3.9-11.18.1
9
运行在以下环境
系统 suse_12_SP4 procps * Up to
(excluding)
3.3.9-11.18.1
10
运行在以下环境
系统 oracle_6 procps * Up to
(excluding)
3.2.8-45.0.1.el6_9.3
11
运行在以下环境
系统 centos_6 procps * Up to
(excluding)
3.2.8-45.el6_9.3
12
运行在以下环境
系统 opensuse_Leap_42.3 procps * Up to
(excluding)
3.3.9-23.1
13
运行在以下环境
系统 opensuse_Leap_15.1 procps * Up to
(excluding)
3.3.15-lp151.6.3.1
14
运行在以下环境
系统 opensuse_Leap_15.0 procps * Up to
(excluding)
3.3.15-lp150.5.3.1
15
运行在以下环境
系统 centos_7 procps * Up to
(excluding)
3.3.10-17.el7_5.2
16
运行在以下环境
系统 oracle_7 procps * Up to
(excluding)
3.3.10-17.el7_5.2
17
运行在以下环境
系统 fedora_27 procps * Up to
(excluding)
3.3.10-16.fc27
18
运行在以下环境
系统 fedora_28 procps * Up to
(excluding)
3.3.12-2.fc28
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况