低危 Oracle Java SE 8u221 libxslt 访问控制漏洞

CVE编号

CVE-2019-11068

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-04-11
漏洞描述
libxslt through 1.1.33 允许绕过保护机制,因为xsltCheckRead和xsltCheckWrite的调用者即使在收到-1错误代码时也允许访问。 xsltCheckRead可以为精心设计的URL返回-1,该URL实际上无效并随后被加载。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 xmlsoft libxslt * Up to
(including)
1.1.33
运行在以下环境
系统 alibaba_cloud_linux_2.1903 libxslt * Up to
(excluding)
1.1.28-6.1.al7
运行在以下环境
系统 alpine_3.10 libxslt * Up to
(excluding)
1.1.33-r1
运行在以下环境
系统 alpine_3.11 libxslt * Up to
(excluding)
1.1.33-r1
运行在以下环境
系统 alpine_3.12 libxslt * Up to
(excluding)
1.1.33-r1
运行在以下环境
系统 alpine_3.13 libxslt * Up to
(excluding)
1.1.33-r1
运行在以下环境
系统 alpine_3.14 libxslt * Up to
(excluding)
1.1.33-r1
运行在以下环境
系统 alpine_3.15 libxslt * Up to
(excluding)
1.1.33-r1
运行在以下环境
系统 alpine_3.6 libxslt * Up to
(excluding)
1.1.29-r4
运行在以下环境
系统 alpine_3.7 libxslt * Up to
(excluding)
1.1.31-r1
运行在以下环境
系统 alpine_3.8 libxslt * Up to
(excluding)
1.1.33-r1
运行在以下环境
系统 alpine_3.9 libxslt * Up to
(excluding)
1.1.33-r1
运行在以下环境
系统 alpine_edge libxslt * Up to
(excluding)
1.1.33-r1
运行在以下环境
系统 amazon_2 libxslt * Up to
(excluding)
1.1.28-6.amzn2
运行在以下环境
系统 amazon_AMI libxslt * Up to
(excluding)
1.1.28-6.15.amzn1
运行在以下环境
系统 centos_8 libxslt * Up to
(excluding)
1.1.32-5.el8
运行在以下环境
系统 debian_10 libxslt * Up to
(excluding)
1.1.32-2.1~deb10u1
运行在以下环境
系统 debian_8 libxslt * Up to
(excluding)
1.1.28-2+deb8u1
运行在以下环境
系统 debian_9 libxslt * Up to
(excluding)
1.1.29-2.1+deb9u1
运行在以下环境
系统 fedora_29 libxslt * Up to
(excluding)
1.1.33-1.fc29
运行在以下环境
系统 fedora_30 libxslt * Up to
(excluding)
1.1.33-1.fc30
运行在以下环境
系统 opensuse_Leap_15.0 libxslt * Up to
(excluding)
2.1.4-lp150.2.16.1
运行在以下环境
系统 opensuse_Leap_15.1 libxslt * Up to
(excluding)
2.3.1-lp151.2.3.1
运行在以下环境
系统 opensuse_Leap_42.3 libxslt * Up to
(excluding)
1.1.28-13.3.1
运行在以下环境
系统 oracle_7 libxslt * Up to
(excluding)
1.1.28-6.0.1.el7
运行在以下环境
系统 oracle_8 libxslt * Up to
(excluding)
1.1.32-5.0.1.el8
运行在以下环境
系统 redhat_8 libxslt * Up to
(excluding)
1.1.32-5.el8
运行在以下环境
系统 suse_12_SP3 libxslt * Up to
(excluding)
1.1.28-17.3.1
运行在以下环境
系统 suse_12_SP4 libxslt * Up to
(excluding)
1.1.28-17.3.1
运行在以下环境
系统 ubuntu_14.04 libxslt * Up to
(excluding)
1.1.28-2ubuntu0.2
运行在以下环境
系统 ubuntu_16.04 libxslt * Up to
(excluding)
1.1.28-2.1ubuntu0.2
运行在以下环境
系统 ubuntu_18.04 libxslt * Up to
(excluding)
1.1.29-5ubuntu0.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况