低危 可利用的代码执行漏洞

CVE编号

CVE-2019-5094

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-09-25 11:15:00
漏洞描述
E2fsprogs 1.45.3的配额文件功能中存在一个可利用的代码执行漏洞。特制的ext4分区可能导致对堆的越界写入,从而导致代码执行。攻击者可以破坏分区以触发此漏洞。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
http://e2fsprogs.sourceforge.net
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 e2fsprogs_project e2fsprogs * From
(including)
1.43.3
Up to
(including)
1.45.3
运行在以下环境
应用 netapp hci_management_node - -
运行在以下环境
应用 netapp solidfire - -
运行在以下环境
系统 alibaba_cloud_linux_2.1903 e2fsprogs * Up to
(excluding)
1.42.9-19.1.al7
运行在以下环境
系统 alpine_3.10 e2fsprogs * Up to
(excluding)
1.45.2-r1
运行在以下环境
系统 alpine_3.11 e2fsprogs * Up to
(excluding)
1.45.4-r0
运行在以下环境
系统 alpine_3.12 e2fsprogs * Up to
(excluding)
1.45.4-r0
运行在以下环境
系统 alpine_3.13 e2fsprogs * Up to
(excluding)
1.45.4-r0
运行在以下环境
系统 alpine_3.14 e2fsprogs * Up to
(excluding)
1.45.4-r0
运行在以下环境
系统 alpine_3.15 e2fsprogs * Up to
(excluding)
1.45.4-r0
运行在以下环境
系统 alpine_3.7 e2fsprogs * Up to
(excluding)
1.43.7-r1
运行在以下环境
系统 alpine_3.8 e2fsprogs * Up to
(excluding)
1.44.2-r1
运行在以下环境
系统 alpine_3.9 e2fsprogs * Up to
(excluding)
1.44.5-r1
运行在以下环境
系统 alpine_edge e2fsprogs * Up to
(excluding)
1.45.4-r0
运行在以下环境
系统 amazon_2 e2fsprogs * Up to
(excluding)
1.42.9-19.amzn2
运行在以下环境
系统 amazon_AMI e2fsprogs * Up to
(excluding)
1.43.5-2.44.amzn1
运行在以下环境
系统 centos_8 e2fsprogs * Up to
(excluding)
1.45.4-3.el8
运行在以下环境
系统 debian_10 e2fsprogs * Up to
(excluding)
1.44.5-1+deb10u2
运行在以下环境
系统 debian_8 e2fsprogs * Up to
(excluding)
1.42.12-2+deb8u1
运行在以下环境
系统 debian_9 e2fsprogs * Up to
(excluding)
1.43.4-2+deb9u1
运行在以下环境
系统 fedora_30 e2fsprogs * Up to
(excluding)
1.44.6-2.fc30
运行在以下环境
系统 fedora_31 e2fsprogs * Up to
(excluding)
1.45.5-1.fc31
运行在以下环境
系统 oracle_7 e2fsprogs * Up to
(excluding)
1.42.9-19.el7
运行在以下环境
系统 oracle_8 e2fsprogs * Up to
(excluding)
1.45.4-3.el8
运行在以下环境
系统 redhat_8 e2fsprogs * Up to
(excluding)
1.45.4-3.el8
运行在以下环境
系统 ubuntu_14.04 e2fsprogs * Up to
(excluding)
1.42.9-3ubuntu1.3+esm1
运行在以下环境
系统 ubuntu_16.04 e2fsprogs * Up to
(excluding)
1.42.13-1ubuntu1.1
运行在以下环境
系统 ubuntu_18.04 e2fsprogs * Up to
(excluding)
1.44.1-1ubuntu1.2
阿里云评分
1.7
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    管控权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况