低危 OpenLDAP 至 2.4.49 slapd filter.c Expression 资源消耗漏洞

CVE编号

CVE-2020-12243

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-04-29 08:15:00
漏洞描述
在2.4.50之前的OpenLDAP中slapd中的filter.c中,带有嵌套boolean表达式的LDAP搜索过滤器会导致拒绝服务(守护程序崩溃)。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://git.openldap.org/openldap/openldap/-/blob/OPENLDAP_REL_ENG_2_4/CHANGES
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 openldap openldap * Up to
(excluding)
2.4.50
运行在以下环境
系统 alibaba_cloud_linux_2.1903 openldap * Up to
(excluding)
2.4.44-22.1.al7
运行在以下环境
系统 alpine_3.10 openldap * Up to
(excluding)
2.4.48-r1
运行在以下环境
系统 alpine_3.11 openldap * Up to
(excluding)
2.4.48-r2
运行在以下环境
系统 alpine_3.12 openldap * Up to
(excluding)
2.4.50-r0
运行在以下环境
系统 alpine_3.13 openldap * Up to
(excluding)
2.4.50-r0
运行在以下环境
系统 alpine_3.14 openldap * Up to
(excluding)
2.4.50-r0
运行在以下环境
系统 alpine_3.15 openldap * Up to
(excluding)
2.4.50-r0
运行在以下环境
系统 alpine_3.8 openldap * Up to
(excluding)
2.4.48-r1
运行在以下环境
系统 alpine_3.9 openldap * Up to
(excluding)
2.4.48-r1
运行在以下环境
系统 alpine_edge openldap * Up to
(excluding)
2.4.50-r0
运行在以下环境
系统 amazon_2 openldap * Up to
(excluding)
2.4.44-22.amzn2
运行在以下环境
系统 debian_10 openldap * Up to
(excluding)
2.4.47+dfsg-3+deb10u2
运行在以下环境
系统 debian_8 openldap * Up to
(excluding)
2.4.40+dfsg-1+deb8u1
运行在以下环境
系统 debian_9 openldap * Up to
(excluding)
2.4.44+dfsg-5+deb9u4
运行在以下环境
系统 opensuse_Leap_15.1 openldap * Up to
(excluding)
2.4.46-lp151.10.9.1
运行在以下环境
系统 oracle_7 openldap * Up to
(excluding)
2.4.44-22.el7
运行在以下环境
系统 suse_12_SP4 openldap * Up to
(excluding)
1.2-18.68.1
运行在以下环境
系统 suse_12_SP5 openldap * Up to
(excluding)
1.2-18.68.1
运行在以下环境
系统 ubuntu_14.04 openldap * Up to
(excluding)
2.4.31-1+nmu2ubuntu8.5+esm2
运行在以下环境
系统 ubuntu_16.04 openldap * Up to
(excluding)
2.4.42+dfsg-2ubuntu3.8
运行在以下环境
系统 ubuntu_18.04 openldap * Up to
(excluding)
2.4.45+dfsg-1ubuntu1.5
运行在以下环境
系统 ubuntu_20.04 openldap * Up to
(excluding)
2.4.49+dfsg-2ubuntu1.2
运行在以下环境
系统 unionos_20 openldap * Up to
(excluding)
2.4.47+dfsg.2-1+eagle
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-400 未加控制的资源消耗(资源穷尽)
CWE-674 未经控制的递归
阿里云安全产品覆盖情况