低危 gnua2ps"Spy_user()"不安全文件创建漏洞

CVE编号

CVE-2001-1593

利用情况

暂无

补丁情况

官方补丁

披露时间

2014-04-06
漏洞描述
在A2PS4.14和更早版本中,temp_user函数和可能的其他函数使用的tempdName_确保函数允许本地用户通过对临时文件的symlink攻击来修改任意文件。 

解决建议
GNU a2ps 4.13已经修复该漏洞,建议用户下载更新:
http://www.gnu.org/s/a2ps/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu a2ps * Up to
(including)
4.14
运行在以下环境
应用 gnu a2ps 4.10.3 -
运行在以下环境
应用 gnu a2ps 4.10.4 -
运行在以下环境
应用 gnu a2ps 4.12 -
运行在以下环境
应用 gnu a2ps 4.13 -
运行在以下环境
应用 gnu a2ps 4.13b -
运行在以下环境
系统 debian_6 a2ps * Up to
(excluding)
1:4.14-1.1+deb6u1
运行在以下环境
系统 debian_7 a2ps * Up to
(excluding)
1:4.14-1.1+deb7u1
阿里云评分
2.3
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    -
CWE-ID 漏洞类型
CWE-59 在文件访问前对链接解析不恰当(链接跟随)
阿里云安全产品覆盖情况