低危 wvware 缓冲区溢出代码执行漏洞

CVE编号

CVE-2004-0645

利用情况

暂无

补丁情况

官方补丁

披露时间

2004-08-06
漏洞描述
wv库(wvWare)0.7.4至0.7.6和1.0.0中wvHandleDateTimePicture函数中的缓冲区溢出允许远程攻击者通过具有较长DateTime字段的文档执行任意代码。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 abisource community_abiword 2.0.3 -
运行在以下环境
应用 abisource community_abiword 2.0.4 -
运行在以下环境
应用 abisource community_abiword 2.0.5 -
运行在以下环境
应用 abisource community_abiword 2.0.6 -
运行在以下环境
应用 abisource community_abiword 2.0.7 -
运行在以下环境
应用 wvware wvware 0.7.4 -
运行在以下环境
应用 wvware wvware 0.7.5 -
运行在以下环境
应用 wvware wvware 0.7.6 -
运行在以下环境
应用 wvware wvware 1.0 -
运行在以下环境
系统 debian_3.0 abiword * Up to
(excluding)
1.0.2+cvs.2002.06.05-1woody2
运行在以下环境
系统 debian_3.0 wv * Up to
(excluding)
1.0.2+cvs.2002.06.05-1woody2
阿里云评分
3.6
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况