低危 Apache HTTP Server 2.0 worker.c 拒绝服务漏洞

CVE编号

CVE-2005-2970

利用情况

暂无

补丁情况

官方补丁

披露时间

2005-10-26
漏洞描述
在某些情况下,Apache 2的worker MPM(worker.c)中的内存泄漏使远程攻击者可以通过中止的连接导致拒绝服务(内存消耗),从而防止事务池的内存被其他连接重用。 。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
参考链接
http://mail-archives.apache.org/mod_mbox/httpd-cvs/200509.mbox/%3C20051001110...
http://rhn.redhat.com/errata/RHSA-2006-0159.html
http://secunia.com/advisories/16559
http://secunia.com/advisories/17923
http://secunia.com/advisories/18161
http://secunia.com/advisories/18333
http://secunia.com/advisories/18585
http://securitytracker.com/id?1015093
http://svn.apache.org/viewcvs?rev=292949&view=rev
http://www.mandriva.com/security/advisories?name=MDKSA-2005:233
http://www.novell.com/linux/security/advisories/2005_28_sr.html
http://www.redhat.com/archives/fedora-announce-list/2006-January/msg00060.html
http://www.securityfocus.com/archive/1/425399/100/0/threaded
http://www.securityfocus.com/bid/15762
https://lists.apache.org/thread.html/54a42d4b01968df1117cea77fc53d6beb931c0e0...
https://lists.apache.org/thread.html/5df9bfb86a3b054bb985a45ff9250b0332c9ecc1...
https://lists.apache.org/thread.html/r0276683d8e1e07153fc8642618830ac0ade85b9...
https://lists.apache.org/thread.html/r2cb985de917e7da0848c440535f65a247754db8...
https://lists.apache.org/thread.html/r5001ecf3d6b2bdd0b732e527654248abb264f08...
https://lists.apache.org/thread.html/r652fc951306cdeca5a276e2021a34878a76695a...
https://lists.apache.org/thread.html/r8828e649175df56f1f9e3919938ac7826128525...
https://lists.apache.org/thread.html/r9e8622254184645bc963a1d47c5d47f6d5a36d6...
https://lists.apache.org/thread.html/r9f93cf6dde308d42a9c807784e8102600d0397f...
https://lists.apache.org/thread.html/rafd145ba6cd0a4ced113a5823cdaff45aeb36eb...
https://lists.apache.org/thread.html/reb542d2038e9c331506e0cbff881b47e40fbe2b...
https://lists.apache.org/thread.html/rf6449464fd8b7437704c55f88361b66f12d5b5f...
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.ova...
https://www.ubuntu.com/usn/usn-225-1/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server 2.0 -
运行在以下环境
系统 debian_3.1 apache2 * Up to
(excluding)
2.0.54-5sarge2
阿里云评分
3.9
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-770 不加限制或调节的资源分配
NVD-CWE-Other
阿里云安全产品覆盖情况