低危 community_abiword 缓冲区溢出代码执行漏洞

CVE编号

CVE-2005-2972

利用情况

EXP 已公开

补丁情况

官方补丁

披露时间

2005-10-23
该漏洞EXP已公开传播,漏洞利用成本极低,建议您立即关注并修复。
漏洞描述
在2.2.11之前,AbiWord的RTF导入功能中的多个基于堆栈的缓冲区溢出允许用户辅助攻击者通过具有长标识符的RTF文件执行任意代码,这在(1)ParseLevelText,(2)get CharsInsideBrace,(3)Handle Lists,(4)或(5)HandleAbi Lists函数中没有得到正确的处理,这是与CVE-2005-2964不同的漏洞。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 abisource community_abiword * Up to
(including)
2.2.10
运行在以下环境
系统 debian_3.0 abiword * Up to
(excluding)
1.0.2+cvs.2002.06.05-1woody3
运行在以下环境
系统 debian_3.1 abiword * Up to
(excluding)
2.2.7-3sarge2
阿里云评分
3.9
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    EXP 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况