中危 AlsaPlayer 0.99.x-多个缓冲区溢出漏洞

CVE编号

CVE-2006-4089

利用情况

暂无

补丁情况

官方补丁

披露时间

2006-08-11
漏洞描述
Andy Lo-A-Foe AlsaPlayer 0.99.76及早期版本存在多个缓冲区溢出漏洞,远程攻击者可借助以下向量触发拒绝服务攻击(应用程序崩溃),也可能存在未知影响:(1) 网络服务器发送的一个超长Location字段,会在reader/http/http.c程序的reconnect函数中引发溢出错误;(2) 在AlsaPlayer寻找播放列表的媒体文件时,一个网络服务器发送的超长URL,会在interface/gtk/PlaylistWindow.cpp程序的new_list_item函数和CbUpdated函数中引发溢出错误;以及(3) CDDB服务器发送的一个超长响应,会在input/ccda/cdda_engine.c程序的cddb_lookup函数中引发溢出错误。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 andy_lo-a-foe alsaplayer * Up to
(including)
0.99.76
运行在以下环境
系统 debian_3.1 alsaplayer * Up to
(excluding)
0.99.76-0.3sarge1
阿里云评分
6.5
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况