低危 graphicsmagick,imagemagick 越界访问拒绝服务代码执行漏洞

CVE编号

CVE-2008-1096

利用情况

暂无

补丁情况

没有补丁

披露时间

2008-03-06
漏洞描述
(1)ImageMagick 6.2.8-0和(2)GraphicsMagick(aka gm)1.1.7中的coders / xcf.c中的XCF编码器中的load_tile函数允许用户辅助的远程攻击者导致拒绝服务(崩溃)或者可能通过精心设计的.xcf文件执行任意代码(该文件触发越界堆写入,这可能与ScaleCharToQuantum函数有关)。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 imagemagick graphicsmagick 1.1.10 -
运行在以下环境
应用 imagemagick graphicsmagick 1.1.11 -
运行在以下环境
应用 imagemagick graphicsmagick 1.1.12 -
运行在以下环境
应用 imagemagick graphicsmagick 1.1.7 -
运行在以下环境
应用 imagemagick graphicsmagick 1.1.8 -
运行在以下环境
应用 imagemagick graphicsmagick 1.1.9 -
运行在以下环境
应用 imagemagick imagemagick 6.2.8.0 -
运行在以下环境
应用 imagemagick imagemagick 6.2.8.1 -
运行在以下环境
应用 imagemagick imagemagick 6.2.8.2 -
运行在以下环境
应用 imagemagick imagemagick 6.2.8.3 -
运行在以下环境
系统 centos_5 graphicsmagick * Up to
(excluding)
6.2.8.0-4.el5_1.1
运行在以下环境
系统 centos_5 imagemagick * Up to
(excluding)
6.2.8.0-4.el5_1.1
运行在以下环境
系统 debian_4.0 graphicsmagick * Up to
(excluding)
1.1.7-13+etch1
运行在以下环境
系统 debian_4.0 imagemagick * Up to
(excluding)
1.1.7-13+etch1
运行在以下环境
系统 debian_5.0 graphicsmagick * Up to
(excluding)
1.1.11-3.2+lenny1
运行在以下环境
系统 debian_5.0 imagemagick * Up to
(excluding)
1.1.11-3.2+lenny1
运行在以下环境
系统 oracle_5 graphicsmagick * Up to
(excluding)
6.2.8.0-4.el5_1.1
运行在以下环境
系统 oracle_5 imagemagick * Up to
(excluding)
6.2.8.0-4.el5_1.1
运行在以下环境
系统 redhat_5 ImageMagick * Up to
(excluding)
0:6.0.7.1-17.el4_6.1
运行在以下环境
系统 suse_10 ImageMagick-Magick++-devel * Up to
(excluding)
6.2.5-16.29
阿里云评分
3.8
  • 攻击路径
    远程
  • 攻击复杂度
    N/A
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    没有补丁
  • 数据保密性
    N/A
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况