中危 graphicsmagick,imagemagick 缓冲区溢出内存破坏拒绝服务代码执行漏洞

CVE编号

CVE-2008-1097

利用情况

暂无

补丁情况

临时补丁

披露时间

2008-03-06
漏洞描述
(1)ImageMagick 6.2.4-5和6.2.8-0以及(2)GraphicsMagick(aka gm)1.1.7中的CoPC / pcx.c中的PCX编码器中的ReadPCXImage函数中的基于堆的缓冲区溢出允许用户协助的远程攻击者通过精心设计的.pcx文件导致拒绝服务(崩溃)或可能执行任意代码(该文件触发scanline 阵列的错误内存分配,从而导致内存损坏)。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 imagemagick graphicsmagick 1.1.10 -
运行在以下环境
应用 imagemagick graphicsmagick 1.1.11 -
运行在以下环境
应用 imagemagick graphicsmagick 1.1.12 -
运行在以下环境
应用 imagemagick graphicsmagick 1.1.7 -
运行在以下环境
应用 imagemagick graphicsmagick 1.1.8 -
运行在以下环境
应用 imagemagick graphicsmagick 1.1.9 -
运行在以下环境
应用 imagemagick imagemagick 6.2.8.0 -
运行在以下环境
应用 imagemagick imagemagick 6.2.8.1 -
运行在以下环境
应用 imagemagick imagemagick 6.2.8.2 -
运行在以下环境
应用 imagemagick imagemagick 6.2.8.3 -
运行在以下环境
系统 centos_5 imagemagick * Up to
(excluding)
6.2.8.0-4.el5_1.1
运行在以下环境
系统 debian_4.0 imagemagick * Up to
(excluding)
7:6.2.4.5.dfsg1-0.15+etch1
运行在以下环境
系统 debian_5.0 imagemagick * Up to
(excluding)
7:6.3.7.9.dfsg2-1~lenny3
运行在以下环境
系统 oracle_5 imagemagick * Up to
(excluding)
6.2.8.0-4.el5_1.1
运行在以下环境
系统 redhat_5 ImageMagick * Up to
(excluding)
0:6.0.7.1-17.el4_6.1
运行在以下环境
系统 suse_10 ImageMagick-Magick++-devel * Up to
(excluding)
6.2.5-16.29
阿里云评分
5.4
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    临时补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    N/A
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-399 资源管理错误
阿里云安全产品覆盖情况