中危 audit 缓冲区溢出代码执行漏洞

CVE编号

CVE-2008-1628

利用情况

暂无

补丁情况

没有补丁

披露时间

2008-04-03
漏洞描述
Linux的lib / audit_logging.c中的audit_log_user_command函数中的audit_log_user_command函数中基于堆栈的缓冲区溢出1.7之前的Audit可能允许远程攻击者通过长命令参数执行任意代码。注意:其中一些详细信息是从第三方信息中获得的。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 linux audit * Up to
(including)
1.6.9
运行在以下环境
系统 debian_5.0 audit * Up to
(excluding)
1.5.3-2+lenny1
阿里云评分
6.3
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    没有补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
CWE-264 权限、特权和访问控制
阿里云安全产品覆盖情况