低危 vim,tar.vim 代码执行漏洞

CVE编号

CVE-2008-3074

利用情况

暂无

补丁情况

没有补丁

披露时间

2009-02-22
漏洞描述
Vim 7.0 through 7.2,包括7.2a.10中的shellescape功能,允许用户协助的攻击者通过“!”(感叹号)shell元字符执行任意代码。 (存在于(1)tar档案的文件名,可能还有(2)tar档案中第一个文件的文件名,VIM TAR plugin (tar.vim) v.10 through v.22没有正确处理,如shellescape,tarplugin.v2,tarplugin和tarplugin.updated测试用例所示。)注意:据报道,由于CVE-2008-2712的修复程序不完整,因此存在此问题。注意:此问题与CVE-2008-3075具有相同的根本原因。注意:由于相关披露的复杂性以及与之相关的不完整信息,此CVE描述和此标识符的外部映射可能存在不准确之处。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vim tar.vim v.10 -
运行在以下环境
应用 vim tar.vim v.11 -
运行在以下环境
应用 vim tar.vim v.12 -
运行在以下环境
应用 vim tar.vim v.13 -
运行在以下环境
应用 vim tar.vim v.14 -
运行在以下环境
应用 vim tar.vim v.15 -
运行在以下环境
应用 vim tar.vim v.16 -
运行在以下环境
应用 vim tar.vim v.17 -
运行在以下环境
应用 vim tar.vim v.18 -
运行在以下环境
应用 vim tar.vim v.19 -
运行在以下环境
应用 vim tar.vim v.20 -
运行在以下环境
应用 vim tar.vim v.21 -
运行在以下环境
应用 vim tar.vim v.22 -
运行在以下环境
应用 vim vim 7.0 -
运行在以下环境
应用 vim vim 7.1 -
运行在以下环境
应用 vim vim 7.1.266 -
运行在以下环境
应用 vim vim 7.1.314 -
运行在以下环境
应用 vim vim 7.2 -
运行在以下环境
系统 centos_5 vim * Up to
(excluding)
7.0.109-4.el5_2.4z
运行在以下环境
系统 debian_4.0 vim * Up to
(excluding)
1:7.0-122+1etch5
运行在以下环境
系统 debian_5.0 vim * Up to
(excluding)
1:7.1.314-3+lenny1
运行在以下环境
系统 debian_6 vim * Up to
(excluding)
1:7.1.314-3+lenny1
运行在以下环境
系统 oracle_5 vim * Up to
(excluding)
7.0.109-4.el5_2.4z
运行在以下环境
系统 redhat_5 vim-X11 * Up to
(excluding)
2:7.0.109-4.el5_2.4z
阿里云评分
3.8
  • 攻击路径
    远程
  • 攻击复杂度
    N/A
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    没有补丁
  • 数据保密性
    N/A
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-78 OS命令中使用的特殊元素转义处理不恰当(OS命令注入)
阿里云安全产品覆盖情况