低危 Netrw 125 Vim Script - 脚本 - 多个命令执行漏洞

CVE编号

CVE-2008-3076

利用情况

暂无

补丁情况

官方补丁

披露时间

2009-02-22
漏洞描述
Vim 7.2a.10中netrw.vim中的Netrw插件125允许用户辅助攻击者通过(1)mz和(2)mc命令(如netrw.v2和netrw.v3测试用例)中执行和系统函数使用的文件名中的shell元字符执行任意代码。注意:据报道,由于CVE-2008-2712的修复程序不完整,因此存在此问题。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vim vim 7.2a.10 -
运行在以下环境
系统 debian_4.0 vim * Up to
(excluding)
1:7.0-122+1etch5
运行在以下环境
系统 debian_5.0 vim * Up to
(excluding)
1:7.1.314-3+lenny1
运行在以下环境
系统 debian_6 vim * Up to
(excluding)
1:7.1.314-3+lenny1
运行在以下环境
系统 oracle_5 vim * Up to
(excluding)
7.0.109-4.el5_2.4z
阿里云评分
3.4
  • 攻击路径
    本地
  • 攻击复杂度
    N/A
  • 权限要求
    N/A
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    N/A
  • 数据完整性
    传输被破坏
  • 服务器危害
    N/A
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-78 OS命令中使用的特殊元素转义处理不恰当(OS命令注入)
阿里云安全产品覆盖情况