中危 avahi up to 0.6.23 originates_from_local_legacy_unicast_socket 拒绝服务漏洞

CVE编号

CVE-2008-5081

利用情况

EXP 已公开

补丁情况

官方补丁

披露时间

2008-12-17 15:30:00
该漏洞EXP已公开传播,漏洞利用成本极低,建议您立即关注并修复。
漏洞描述
在0.6.24之前Avahi的avahi-daemon中的originates_from_local_legacy_unicast_socket函数(avahi-core / server.c)允许远程攻击者通过具有source port of 0的精心设计的mDNS数据包,触发断言失败,导致拒绝服务(崩溃)。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 avahi avahi * Up to
(including)
0.6.23
运行在以下环境
应用 avahi avahi 0.1 -
运行在以下环境
应用 avahi avahi 0.2 -
运行在以下环境
应用 avahi avahi 0.3 -
运行在以下环境
应用 avahi avahi 0.4 -
运行在以下环境
应用 avahi avahi 0.5 -
运行在以下环境
应用 avahi avahi 0.5.1 -
运行在以下环境
应用 avahi avahi 0.5.2 -
运行在以下环境
应用 avahi avahi 0.6.1 -
运行在以下环境
应用 avahi avahi 0.6.10 -
运行在以下环境
应用 avahi avahi 0.6.11 -
运行在以下环境
应用 avahi avahi 0.6.12 -
运行在以下环境
应用 avahi avahi 0.6.13 -
运行在以下环境
应用 avahi avahi 0.6.14 -
运行在以下环境
应用 avahi avahi 0.6.15 -
运行在以下环境
应用 avahi avahi 0.6.16 -
运行在以下环境
应用 avahi avahi 0.6.17 -
运行在以下环境
应用 avahi avahi 0.6.18 -
运行在以下环境
应用 avahi avahi 0.6.19 -
运行在以下环境
应用 avahi avahi 0.6.2 -
运行在以下环境
应用 avahi avahi 0.6.20 -
运行在以下环境
应用 avahi avahi 0.6.21 -
运行在以下环境
应用 avahi avahi 0.6.22 -
运行在以下环境
应用 avahi avahi 0.6.3 -
运行在以下环境
应用 avahi avahi 0.6.4 -
运行在以下环境
应用 avahi avahi 0.6.5 -
运行在以下环境
应用 avahi avahi 0.6.6 -
运行在以下环境
应用 avahi avahi 0.6.7 -
运行在以下环境
应用 avahi avahi 0.6.8 -
运行在以下环境
应用 avahi avahi 0.6.9 -
运行在以下环境
系统 centos_5 avahi * Up to
(excluding)
0.6.16-1.el5_2.1
运行在以下环境
系统 debian_4.0 avahi * Up to
(excluding)
0.6.16-3etch2
运行在以下环境
系统 debian_5.0 avahi * Up to
(excluding)
0.6.22-3+lenny1
运行在以下环境
系统 oracle_5 avahi * Up to
(excluding)
0.6.16-1.el5_2.1
阿里云评分
5.1
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    EXP 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-399 资源管理错误
阿里云安全产品覆盖情况