中危 vim 代码执行漏洞

CVE编号

CVE-2008-6235

利用情况

暂无

补丁情况

官方补丁

披露时间

2009-02-22
漏洞描述
Vim 7.0和7.1中的Netrw插件(netrw.vim)允许用户辅助攻击者通过(1)“D”(删除)命令或(2)b:netrw_curdir变量使用的文件名中的shell元字符执行任意命令,正如使用netrw.v4和netrw.v5test案例所示。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vim vim 7.0 -
运行在以下环境
应用 vim vim 7.1 -
运行在以下环境
系统 centos_5 vim-common * Up to
(excluding)
7.0.109-4.el5_2.4z
运行在以下环境
系统 centos_5 vim-enhanced * Up to
(excluding)
7.0.109-4.el5_2.4z
运行在以下环境
系统 centos_5 vim-minimal * Up to
(excluding)
7.0.109-4.el5_2.4z
运行在以下环境
系统 centos_5 vim-X11 * Up to
(excluding)
7.0.109-4.el5_2.4z
运行在以下环境
系统 oracle_5 vim-common * Up to
(excluding)
7.0.109-4.el5_2.4z
运行在以下环境
系统 oracle_5 vim-enhanced * Up to
(excluding)
7.0.109-4.el5_2.4z
运行在以下环境
系统 oracle_5 vim-minimal * Up to
(excluding)
7.0.109-4.el5_2.4z
运行在以下环境
系统 oracle_5 vim-X11 * Up to
(excluding)
7.0.109-4.el5_2.4z
运行在以下环境
系统 redhat_5 vim-X11 * Up to
(excluding)
2:7.0.109-4.el5_2.4z
阿里云评分
6.0
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-78 OS命令中使用的特殊元素转义处理不恰当(OS命令注入)
阿里云安全产品覆盖情况