低危 dbus 欺骗漏洞

CVE编号

CVE-2009-1189

利用情况

暂无

补丁情况

官方补丁

披露时间

2009-04-28
漏洞描述
在1.2.14之前的D-Bus(也称为DBus)中的_dbus_validate_signature_with_reason函数(dbus-marshal-validate.c)使用不正确的逻辑来验证基本类型,这允许远程攻击者通过精心制作的密钥欺骗签名。注意:这是由于CVE-2008-3834的错误修复。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 freedesktop dbus * Up to
(including)
1.2.3
运行在以下环境
应用 freedesktop dbus 0.1 -
运行在以下环境
应用 freedesktop dbus 0.10 -
运行在以下环境
应用 freedesktop dbus 0.11 -
运行在以下环境
应用 freedesktop dbus 0.12 -
运行在以下环境
应用 freedesktop dbus 0.13 -
运行在以下环境
应用 freedesktop dbus 0.2 -
运行在以下环境
应用 freedesktop dbus 0.20 -
运行在以下环境
应用 freedesktop dbus 0.21 -
运行在以下环境
应用 freedesktop dbus 0.22 -
运行在以下环境
应用 freedesktop dbus 0.23 -
运行在以下环境
应用 freedesktop dbus 0.23.1 -
运行在以下环境
应用 freedesktop dbus 0.23.2 -
运行在以下环境
应用 freedesktop dbus 0.23.3 -
运行在以下环境
应用 freedesktop dbus 0.3 -
运行在以下环境
应用 freedesktop dbus 0.31 -
运行在以下环境
应用 freedesktop dbus 0.32 -
运行在以下环境
应用 freedesktop dbus 0.33 -
运行在以下环境
应用 freedesktop dbus 0.34 -
运行在以下环境
应用 freedesktop dbus 0.35 -
运行在以下环境
应用 freedesktop dbus 0.35.1 -
运行在以下环境
应用 freedesktop dbus 0.35.2 -
运行在以下环境
应用 freedesktop dbus 0.36 -
运行在以下环境
应用 freedesktop dbus 0.36.1 -
运行在以下环境
应用 freedesktop dbus 0.36.2 -
运行在以下环境
应用 freedesktop dbus 0.4 -
运行在以下环境
应用 freedesktop dbus 0.5 -
运行在以下环境
应用 freedesktop dbus 0.50 -
运行在以下环境
应用 freedesktop dbus 0.6 -
运行在以下环境
应用 freedesktop dbus 0.60 -
运行在以下环境
应用 freedesktop dbus 0.61 -
运行在以下环境
应用 freedesktop dbus 0.62 -
运行在以下环境
应用 freedesktop dbus 0.7 -
运行在以下环境
应用 freedesktop dbus 0.8 -
运行在以下环境
应用 freedesktop dbus 0.9 -
运行在以下环境
应用 freedesktop dbus 0.90 -
运行在以下环境
应用 freedesktop dbus 0.91 -
运行在以下环境
应用 freedesktop dbus 0.92 -
运行在以下环境
应用 freedesktop dbus 1.0 -
运行在以下环境
应用 freedesktop dbus 1.0.2 -
运行在以下环境
应用 freedesktop dbus 1.1.0 -
运行在以下环境
应用 freedesktop dbus 1.1.1 -
运行在以下环境
应用 freedesktop dbus 1.1.2 -
运行在以下环境
应用 freedesktop dbus 1.1.20 -
运行在以下环境
应用 freedesktop dbus 1.1.4 -
运行在以下环境
应用 freedesktop dbus 1.2.1 -
运行在以下环境
系统 centos_5 dbus * Up to
(excluding)
1.1.2-12.el5_4.1
运行在以下环境
系统 debian_4.0 dbus * Up to
(excluding)
1.0.2-1+etch3
运行在以下环境
系统 debian_5.0 dbus * Up to
(excluding)
1.2.1-5+lenny1
运行在以下环境
系统 oracle_5 dbus * Up to
(excluding)
1.1.2-12.el5_4.1
阿里云评分
3.5
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况