中危 linux_kernel,kernel 缓冲区溢出内存破坏拒绝服务漏洞

CVE编号

CVE-2009-1389

利用情况

暂无

补丁情况

官方补丁

披露时间

2009-06-17
漏洞描述
2.6.30之前Linux内核中的RTL8169 NIC驱动程序(drivers / net / r8169.c)中的缓冲区溢出允许远程攻击者通过长数据包导致拒绝服务(内核内存损坏和崩溃)。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
参考链接
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff...
http://lists.opensuse.org/opensuse-security-announce/2009-07/msg00004.html
http://lists.opensuse.org/opensuse-security-announce/2010-07/msg00006.html
http://lkml.org/lkml/2009/6/8/194
http://marc.info/?l=linux-netdev&m=123462461713724&w=2
http://secunia.com/advisories/35265
http://secunia.com/advisories/35566
http://secunia.com/advisories/35847
http://secunia.com/advisories/36045
http://secunia.com/advisories/36051
http://secunia.com/advisories/36131
http://secunia.com/advisories/36327
http://secunia.com/advisories/37298
http://secunia.com/advisories/37471
http://secunia.com/advisories/40645
http://support.avaya.com/css/P8/documents/100067254
http://support.citrix.com/article/CTX123453
http://wiki.rpath.com/Advisories:rPSA-2009-0111
http://www.debian.org/security/2009/dsa-1844
http://www.debian.org/security/2009/dsa-1865
http://www.mandriva.com/security/advisories?name=MDVSA-2009:148
http://www.openwall.com/lists/oss-security/2009/06/10/1
http://www.redhat.com/support/errata/RHSA-2009-1157.html
http://www.redhat.com/support/errata/RHSA-2009-1193.html
http://www.securityfocus.com/archive/1/505254/100/0/threaded
http://www.securityfocus.com/archive/1/507985/100/0/threaded
http://www.securityfocus.com/bid/35281
http://www.securitytracker.com/id?1023507
http://www.ubuntu.com/usn/usn-807-1
http://www.vmware.com/security/advisories/VMSA-2009-0016.html
http://www.vupen.com/english/advisories/2009/3316
http://www.vupen.com/english/advisories/2010/0219
http://www.vupen.com/english/advisories/2010/1857
https://bugzilla.redhat.com/show_bug.cgi?id=504726
https://exchange.xforce.ibmcloud.com/vulnerabilities/51051
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.ova...
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.ova...
https://www.redhat.com/archives/fedora-package-announce/2009-June/msg01048.html
https://www.redhat.com/archives/fedora-package-announce/2009-June/msg01094.html
https://www.redhat.com/archives/fedora-package-announce/2009-June/msg01193.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 linux kernel 2.6.24.7 -
运行在以下环境
应用 linux kernel 2.6.25.15 -
运行在以下环境
系统 centos_5 kernel * Up to
(excluding)
2.6.18-128.4.1.el5
运行在以下环境
系统 opensuse_10.3 kernel * Up to
(excluding)
2.6.22.19-0.4
运行在以下环境
系统 opensuse_11.0 kernel * Up to
(excluding)
2.6.25.20-0.5
运行在以下环境
系统 opensuse_11.1 kernel * Up to
(excluding)
2.6.27.29-0.1.1
运行在以下环境
系统 opensuse_11.2 kernel * Up to
(excluding)
2.6.31.14-0.1.1
运行在以下环境
系统 oracle_5 kernel * Up to
(excluding)
2.6.18-164.el5
运行在以下环境
系统 redhat_5 kernel * Up to
(excluding)
0:2.6.18-128.4.1.el5
运行在以下环境
系统 suse_11 ext4dev-kmp-default * Up to
(excluding)
0_2.6.27.48_0.1-7.1
阿里云评分
6.9
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况