低危 Apache HTTP Server 2.2.13 mod_proxy_ftp ap_proxy_ftp_handler 拒绝服务漏洞

CVE编号

CVE-2009-3094

利用情况

暂无

补丁情况

官方补丁

披露时间

2009-09-09
漏洞描述
在ApacheHTTP Server2.0.63和2.2.13中的mod_proxy_ftp_handler模块/proxy/proxy_ftp.c中的ap_proxy_ftp.函数允许远程FTP服务器通过对EPSV命令的格式错误的回复导致拒绝服务(NULL指针反引用和子进程崩溃)。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
参考链接
http://intevydis.com/vd-list.shtml
http://lists.opensuse.org/opensuse-security-announce/2009-10/msg00006.html
http://marc.info/?l=bugtraq&m=126998684522511&w=2
http://marc.info/?l=bugtraq&m=127557640302499&w=2
http://marc.info/?l=bugtraq&m=133355494609819&w=2
http://secunia.com/advisories/36549
http://secunia.com/advisories/37152
http://wiki.rpath.com/Advisories:rPSA-2009-0155
http://www-01.ibm.com/support/docview.wss?uid=swg1PK96858
http://www-01.ibm.com/support/docview.wss?uid=swg1PM09161
http://www.debian.org/security/2009/dsa-1934
http://www.intevydis.com/blog/?p=59
http://www.securityfocus.com/archive/1/508075/100/0/threaded
http://www.vupen.com/english/advisories/2010/0609
https://bugzilla.redhat.com/show_bug.cgi?id=521619
https://lists.apache.org/thread.html/54a42d4b01968df1117cea77fc53d6beb931c0e0...
https://lists.apache.org/thread.html/5df9bfb86a3b054bb985a45ff9250b0332c9ecc1...
https://lists.apache.org/thread.html/8d63cb8e9100f28a99429b4328e4e7cebce861d5...
https://lists.apache.org/thread.html/f7f95ac1cd9895db2714fa3ebaa0b94d0c6df360...
https://lists.apache.org/thread.html/r0276683d8e1e07153fc8642618830ac0ade85b9...
https://lists.apache.org/thread.html/r2295080a257bad27ea68ca0af12fc715577f9e8...
https://lists.apache.org/thread.html/r2cb985de917e7da0848c440535f65a247754db8...
https://lists.apache.org/thread.html/r57608dc51b79102f3952ae06f54d5277b649c86...
https://lists.apache.org/thread.html/r5f9c22f9c28adbd9f00556059edc7b03a5d5bb7...
https://lists.apache.org/thread.html/r75cbe9ea3e2114e4271bbeca7aff96117b50c1b...
https://lists.apache.org/thread.html/r8828e649175df56f1f9e3919938ac7826128525...
https://lists.apache.org/thread.html/r9e8622254184645bc963a1d47c5d47f6d5a36d6...
https://lists.apache.org/thread.html/r9ea3538f229874c80a10af473856a81fbf5f694...
https://lists.apache.org/thread.html/r9f93cf6dde308d42a9c807784e8102600d0397f...
https://lists.apache.org/thread.html/rad01d817195e6cc871cb1d73b207ca326379a20...
https://lists.apache.org/thread.html/rad2acee3ab838b52c04a0698b1728a9a43467bf...
https://lists.apache.org/thread.html/rb9c9f42dafa25d2f669dac2a536a03f2575bc5e...
https://lists.apache.org/thread.html/rdca61ae990660bacb682295f2a09d34612b7bb5...
https://lists.apache.org/thread.html/reb7c64aeea604bf948467d9d1cab8ff23fa7d00...
https://lists.apache.org/thread.html/rf6449464fd8b7437704c55f88361b66f12d5b5f...
https://lists.apache.org/thread.html/rfbaf647d52c1cb843e726a0933f156366a806ce...
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.ova...
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.ova...
https://www.redhat.com/archives/fedora-package-announce/2009-December/msg00645.html
https://www.redhat.com/archives/fedora-package-announce/2009-December/msg00944.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server 2.0.63 -
运行在以下环境
应用 apache http_server 2.2.13 -
运行在以下环境
系统 centos_5 apache2 * Up to
(excluding)
2.2.3-31.el5.centos.2
运行在以下环境
系统 debian_4.0 apache2 * Up to
(excluding)
2.2.3-4+etch11
运行在以下环境
系统 debian_5.0 apache2 * Up to
(excluding)
2.2.9-10+lenny6
运行在以下环境
系统 opensuse_10.3 apache2 * Up to
(excluding)
2.2.4-70.11
运行在以下环境
系统 opensuse_11.0 apache2 * Up to
(excluding)
2.2.8-28.8
运行在以下环境
系统 opensuse_11.1 apache2 * Up to
(excluding)
2.2.10-2.8.1
运行在以下环境
系统 oracle_5 apache2 * Up to
(excluding)
2.2.3-31.0.1.el5_4.2
运行在以下环境
系统 redhat_5 httpd * Up to
(excluding)
0:2.2.3-31.el5_4.2
运行在以下环境
系统 suse_12 apache2 * Up to
(excluding)
2.4.10-6
阿里云评分
2.3
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    -
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况