中危 aria2 缓冲区溢出拒绝服务代码执行漏洞

CVE编号

CVE-2009-3575

利用情况

暂无

补丁情况

官方补丁

披露时间

2009-10-08
漏洞描述
aria2 0.15.3、1.2.0和其他版本中的DHTRoutingTableDeserializer.cc和其他版本中的缓冲区溢出使远程攻击者可以导致拒绝服务(崩溃)并可能通过未知矢量执行任意代码。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.15.3 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.2.0 -
运行在以下环境
系统 debian_5.0 aria2 * Up to
(excluding)
0.14.0-1+lenny1
运行在以下环境
系统 ubuntu_14.04.6_lts aria2 * Up to
(excluding)
1.18.1-1
运行在以下环境
系统 ubuntu_16.04.7_lts aria2 * Up to
(excluding)
1.18.1-1
运行在以下环境
系统 ubuntu_18.04.5_lts aria2 * Up to
(excluding)
1.18.1-1
阿里云评分
6.8
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况