低危 GNU Automake 不安全目录许可权限漏洞

CVE编号

CVE-2009-4029

利用情况

暂无

补丁情况

官方补丁

披露时间

2009-12-20
漏洞描述
当为使用Automake的package生成 distribution tarball时,在(1)dist或(2)distcheck规则在GNU Automake 1.11.1,1.10.3和 branch-1-4 through branch-1-9中向build tree中的目录分配了不安全的权限(777),从而引入一个竞争条件,允许本地用户修改数据包文件的内容、引入特洛伊木马程序或在构建完成之前进行其他攻击。 

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu automake 1.10.3 -
运行在以下环境
应用 gnu automake 1.11.1 -
运行在以下环境
应用 gnu automake branch -
运行在以下环境
系统 oracle_5 automake * Up to
(excluding)
1.4p6-13.el5.1
运行在以下环境
系统 oracle_5 automake14 * Up to
(excluding)
1.4p6-13.el5.1
运行在以下环境
系统 oracle_5 automake15 * Up to
(excluding)
1.4p6-13.el5.1
运行在以下环境
系统 oracle_5 automake16 * Up to
(excluding)
1.4p6-13.el5.1
运行在以下环境
系统 oracle_5 automake17 * Up to
(excluding)
1.4p6-13.el5.1
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-362 使用共享资源的并发执行不恰当同步问题(竞争条件)
阿里云安全产品覆盖情况