中危 Nginx 0.7.64 - Terminal Escape Sequence in Logs 命令注入漏洞

CVE编号

CVE-2009-4487

利用情况

暂无

补丁情况

没有补丁

披露时间

2010-01-14
漏洞描述
nginx0.7.64将数据写入日志文件,而不对不可打印的字符进行消毒,这可能允许远程攻击者通过包含终端仿真器转义序列的HTTP请求修改窗口标题,或者可能执行任意命令或覆盖文件。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 nginx nginx * -
运行在以下环境
系统 debian_10 nginx * Up to
(including)
1.14.2-2+deb10u4
运行在以下环境
系统 debian_11 nginx * Up to
(including)
1.18.0-6.1
运行在以下环境
系统 debian_12 nginx * Up to
(including)
1.20.2-2
运行在以下环境
系统 debian_9 nginx * Up to
(including)
1.10.3-1+deb9u4
运行在以下环境
系统 debian_sid nginx * Up to
(including)
1.20.2-2
阿里云评分
5.5
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    N/A
  • 补丁情况
    没有补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况