低危 GNU C Library 代码问题漏洞

CVE编号

CVE-2009-5155

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-02-26
漏洞描述
GNU C Library(glibc,libc6)是一种按照LGPL许可协议发布的开源免费的C语言编译程序。
GNU C Library 2.28之前版本中的posix/regcomp.c文件的parse_reg_exp存在安全漏洞。攻击者可利用该漏洞造成拒绝服务(断言失败及应用程序退出)或其他危害。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu glibc * Up to
(excluding)
2.28
运行在以下环境
应用 netapp cloud_backup * -
运行在以下环境
应用 netapp ontap_select_deploy_administration_utility - -
运行在以下环境
应用 netapp steelstore_cloud_integrated_storage - -
运行在以下环境
系统 debian_9 glibc * Up to
(excluding)
20140202+stable-2+deb9u1
运行在以下环境
系统 debian_9 gnulib * Up to
(excluding)
20140202+stable-2+deb9u1
运行在以下环境
系统 suse_12_SP4 glibc * Up to
(excluding)
2.22-100.8.1
运行在以下环境
系统 suse_12_SP4 gnulib * Up to
(excluding)
2.22-100.8.1
运行在以下环境
系统 ubuntu_16.04 glibc * Up to
(excluding)
2.23-0ubuntu11.3
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
阿里云安全产品覆盖情况