低危 aria2 <1.9.3 Metalink文件处理目录遍历漏洞

CVE编号

CVE-2010-1512

利用情况

暂无

补丁情况

官方补丁

披露时间

2010-05-18
漏洞描述
目录遍历漏洞在aria2之前1.9.3允许远程攻击者通过目录遍历序列在metalink文件中的文件元素的name属性中创建任意文件..
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 * Up to
(including)
1.9.2
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.1.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.10.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.10.0+1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.10.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.10.2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.10.2+1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.11.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.11.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.11.1+1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.11.2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.11.3 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.11.4 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.11.5 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.12.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.12.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.13.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.13.0+1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.13.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.13.1+1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.13.1+2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.13.2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.13.2+1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.14.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.14.0+1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.15.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.15.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.15.1+1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.15.1+2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.15.2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.15.3 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.16.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.16.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.16.2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.2.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.2.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.2.1+1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.2.1+2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.3.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.3.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.3.1+1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.3.1+2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.3.2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.4.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.4.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.5.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.5.0+1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.5.0+2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.5.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.5.2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.6.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.6.0+1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.7.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.7.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.7.2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.7.3 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.8.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.8.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 0.9.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.0.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.0.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.1.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.1.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.1.2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.2.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.3.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.3.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.3.2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.3.3 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.4.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.4.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.5.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.5.0b+20090716 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.5.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.5.2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.6.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.6.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.6.2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.6.3 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.7.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.7.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.7.2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.8.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.8.1 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.8.2 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.8.3 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.9.0 -
运行在以下环境
应用 tatsuhiro_tsujikawa aria2 1.9.1 -
运行在以下环境
系统 debian_5.0 aria2 * Up to
(excluding)
0.14.0-1+lenny2
运行在以下环境
系统 ubuntu_12.04.5_lts aria2 * Up to
(excluding)
1.9.3-1
阿里云评分
3.4
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-22 对路径名的限制不恰当(路径遍历)
阿里云安全产品覆盖情况