中危 PHP 至 5.3.2 fnmatch first 资源管理漏洞

CVE编号

CVE-2010-1917

利用情况

暂无

补丁情况

N/A

披露时间

2010-05-13
漏洞描述
PHP是广泛使用的通用目的脚本语言,特别适合于Web开发,可嵌入到HTML中。PHP 5.2和5.3存在堆栈消耗漏洞,上下文依赖的攻击者可通过fnmatch函数特制的的第一参数引发拒绝服务(PHP崩溃),比如使用长字符串。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 php php 5.2.0 -
运行在以下环境
应用 php php 5.2.1 -
运行在以下环境
应用 php php 5.2.10 -
运行在以下环境
应用 php php 5.2.11 -
运行在以下环境
应用 php php 5.2.12 -
运行在以下环境
应用 php php 5.2.13 -
运行在以下环境
应用 php php 5.2.2 -
运行在以下环境
应用 php php 5.2.3 -
运行在以下环境
应用 php php 5.2.4 -
运行在以下环境
应用 php php 5.2.5 -
运行在以下环境
应用 php php 5.2.6 -
运行在以下环境
应用 php php 5.2.8 -
运行在以下环境
应用 php php 5.2.9 -
运行在以下环境
应用 php php 5.3.0 -
运行在以下环境
应用 php php 5.3.1 -
运行在以下环境
应用 php php 5.3.2 -
运行在以下环境
系统 centos_5 php * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 centos_5 php-bcmath * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 centos_5 php-cli * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 centos_5 php-common * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 centos_5 php-dba * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 centos_5 php-devel * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 centos_5 php-gd * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 centos_5 php-imap * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 centos_5 php-ldap * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 centos_5 php-mbstring * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 centos_5 php-mysql * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 centos_5 php-ncurses * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 centos_5 php-odbc * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 centos_5 php-pdo * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 centos_5 php-pgsql * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 centos_5 php-snmp * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 centos_5 php-soap * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 centos_5 php-xml * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 centos_5 php-xmlrpc * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php-bcmath * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php-cli * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php-common * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php-dba * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php-devel * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php-gd * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php-imap * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php-ldap * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php-mbstring * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php-mysql * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php-ncurses * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php-odbc * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php-pdo * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php-pgsql * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php-snmp * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php-soap * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php-xml * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 oracle_5 php-xmlrpc * Up to
(excluding)
5.1.6-27.el5_5.3
运行在以下环境
系统 redhat_5 php * Up to
(excluding)
0:4.3.9-3.31
阿里云评分
5.8
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    N/A
  • 补丁情况
    N/A
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-399 资源管理错误
阿里云安全产品覆盖情况