低危 Avahi 0.6.16-0.6.25 AvahiDnsPacket 拒绝服务漏洞

CVE编号

CVE-2010-2244

利用情况

暂无

补丁情况

官方补丁

披露时间

2010-07-09 01:54:00
漏洞描述
 
Avahi 0.6.16和0.6.25中的avahi-daemon中的avahi-core / socket.c中的AvahiDnsPacket函数允许远程攻击者通过带有无效校验和的DNS数据包和带有有效校验和的DNS数据包导致拒绝服务(断言失败和守护进程退出),这与CVE-2008-5081不同。 

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 avahi avahi 0.6.16 -
运行在以下环境
应用 avahi avahi 0.6.25 -
运行在以下环境
系统 centos_5 avahi * Up to
(excluding)
0.6.16-9.el5_5
运行在以下环境
系统 debian_5.0 avahi * Up to
(excluding)
0.6.23-3lenny2
运行在以下环境
系统 oracle_5 avahi * Up to
(excluding)
0.6.16-9.el5_5
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况