gvim 代码执行漏洞

CVE编号

CVE-2010-3914

利用情况

暂无

补丁情况

N/A

披露时间

2010-11-04
漏洞描述
在7.3.034之前的VIM开发组GVim中不受信任的搜索路径漏洞,以及在7.3.46之前可能的其他版本,允许本地用户,可能还有远程攻击者执行任意代码,并通过木马User32.dll或位于与 .TXT文件相同文件夹中的其他DLL进行DLL劫持攻击。 注:其中一些细节是从第三方信息中获得的。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接: ftp://ftp.vim.org/pub/vim/patches/7.3/7.3.034
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vim gvim * Up to
(including)
7.3.033
运行在以下环境
应用 vim gvim 7.3.01 -
运行在以下环境
应用 vim gvim 7.3.010 -
运行在以下环境
应用 vim gvim 7.3.011 -
运行在以下环境
应用 vim gvim 7.3.012 -
运行在以下环境
应用 vim gvim 7.3.013 -
运行在以下环境
应用 vim gvim 7.3.014 -
运行在以下环境
应用 vim gvim 7.3.015 -
运行在以下环境
应用 vim gvim 7.3.016 -
运行在以下环境
应用 vim gvim 7.3.017 -
运行在以下环境
应用 vim gvim 7.3.018 -
运行在以下环境
应用 vim gvim 7.3.019 -
运行在以下环境
应用 vim gvim 7.3.02 -
运行在以下环境
应用 vim gvim 7.3.020 -
运行在以下环境
应用 vim gvim 7.3.021 -
运行在以下环境
应用 vim gvim 7.3.022 -
运行在以下环境
应用 vim gvim 7.3.023 -
运行在以下环境
应用 vim gvim 7.3.024 -
运行在以下环境
应用 vim gvim 7.3.025 -
运行在以下环境
应用 vim gvim 7.3.026 -
运行在以下环境
应用 vim gvim 7.3.027 -
运行在以下环境
应用 vim gvim 7.3.028 -
运行在以下环境
应用 vim gvim 7.3.029 -
运行在以下环境
应用 vim gvim 7.3.03 -
运行在以下环境
应用 vim gvim 7.3.030 -
运行在以下环境
应用 vim gvim 7.3.031 -
运行在以下环境
应用 vim gvim 7.3.032 -
运行在以下环境
应用 vim gvim 7.3.04 -
运行在以下环境
应用 vim gvim 7.3.05 -
运行在以下环境
应用 vim gvim 7.3.06 -
运行在以下环境
应用 vim gvim 7.3.07 -
运行在以下环境
应用 vim gvim 7.3.08 -
运行在以下环境
应用 vim gvim 7.3.09 -
CVSS3评分
9.3
  • 攻击路径
    网络
  • 攻击复杂度
    N/A
  • 权限要求
  • 影响范围
    N/A
  • 用户交互
    需要
  • 可用性
    完全地
  • 保密性
    完全地
  • 完整性
    完全地
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况