PHP 5.2.x<5.2.15,5.3.x<5.3.4 IMAP扩展imap_do_open函数双重释放拒绝服务漏洞

CVE编号

CVE-2010-4150

利用情况

暂无

补丁情况

N/A

披露时间

2010-12-08
漏洞描述
5.2.15之前的PHP 5.2和5.3.4之前的5.3的IMAP扩展(ext/ IMAP /php_imap.c)中的imap_do_open函数中的Double free漏洞允许攻击者导致拒绝服务(内存损坏)或可能通过未指定的向量执行任意代码。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接: http://svn.php.net/viewvc?view=revision&revision=305032
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 php php 5.2.0 -
运行在以下环境
应用 php php 5.2.1 -
运行在以下环境
应用 php php 5.2.10 -
运行在以下环境
应用 php php 5.2.11 -
运行在以下环境
应用 php php 5.2.12 -
运行在以下环境
应用 php php 5.2.13 -
运行在以下环境
应用 php php 5.2.14 -
运行在以下环境
应用 php php 5.2.2 -
运行在以下环境
应用 php php 5.2.3 -
运行在以下环境
应用 php php 5.2.4 -
运行在以下环境
应用 php php 5.3.0 -
运行在以下环境
应用 php php 5.3.1 -
运行在以下环境
应用 php php 5.3.2 -
运行在以下环境
应用 php php 5.3.3 -
运行在以下环境
系统 suse_12 apache2-mod_php5 * Up to
(excluding)
5.5.14-4
运行在以下环境
系统 ubuntu_12.04.5_lts php-imap * Up to
(excluding)
5.3.5-0ubuntu1
运行在以下环境
系统 ubuntu_12.04_lts php-imap * Up to
(excluding)
5.3.5-0ubuntu1
运行在以下环境
系统 ubuntu_14.04.6_lts php-imap * Up to
(excluding)
5.3.5-0ubuntu1
运行在以下环境
系统 ubuntu_14.04_lts php-imap * Up to
(excluding)
5.3.5-0ubuntu1
CVSS3评分
5.0
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    N/A
  • 用户交互
  • 可用性
    部分地
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-399 资源管理错误
阿里云安全产品覆盖情况