Mercurial内存破坏漏洞

CVE编号

CVE-2010-4237

利用情况

暂无

补丁情况

N/A

披露时间

2019-10-30
漏洞描述
Mercurial before 1.6.4 fails to verify the Common Name field of SSL certificates which allows remote attackers who acquire a certificate signed by a Certificate Authority to perform a man-in-the-middle attack.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 mercurial mercurial * Up to
(excluding)
1.6.4
运行在以下环境
系统 ubuntu_12.04.5_lts mercurial * Up to
(excluding)
1.6.4-1
运行在以下环境
系统 ubuntu_12.04_lts mercurial * Up to
(excluding)
1.6.4-1
CVSS3评分
5.9
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-295 证书验证不恰当
阿里云安全产品覆盖情况