高危 awstats 代码执行漏洞

CVE编号

CVE-2010-4368

利用情况

暂无

补丁情况

N/A

披露时间

2010-12-03 05:22:00
漏洞描述
在Windows7.0之前,AW Stats中的awstats.cgi接受URL中的configdir参数,该参数允许远程攻击者通过位于UNC共享路径名的精心制作的配置文件执行任意命令。
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接: http://awstats.sourceforge.net/docs/awstats_changelog.txt
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 awstats awstats * Up to
(including)
6.95
运行在以下环境
应用 awstats awstats 1.0 -
运行在以下环境
应用 awstats awstats 2.1. -
运行在以下环境
应用 awstats awstats 2.2.3 -
运行在以下环境
应用 awstats awstats 2.2.4 -
运行在以下环境
应用 awstats awstats 3.0 -
运行在以下环境
应用 awstats awstats 3.1 -
运行在以下环境
应用 awstats awstats 3.2 -
运行在以下环境
应用 awstats awstats 4.0 -
运行在以下环境
应用 awstats awstats 4.1 -
运行在以下环境
应用 awstats awstats 5.0 -
运行在以下环境
应用 awstats awstats 5.1 -
运行在以下环境
应用 awstats awstats 5.2 -
运行在以下环境
应用 awstats awstats 5.3 -
运行在以下环境
应用 awstats awstats 5.4 -
运行在以下环境
应用 awstats awstats 5.5 -
运行在以下环境
应用 awstats awstats 5.6 -
运行在以下环境
应用 awstats awstats 5.7 -
运行在以下环境
应用 awstats awstats 5.8 -
运行在以下环境
应用 awstats awstats 5.9 -
运行在以下环境
应用 awstats awstats 6.0 -
运行在以下环境
应用 awstats awstats 6.1 -
运行在以下环境
应用 awstats awstats 6.2 -
运行在以下环境
应用 awstats awstats 6.3 -
运行在以下环境
应用 awstats awstats 6.4 -
运行在以下环境
应用 awstats awstats 6.4_1 -
运行在以下环境
应用 awstats awstats 6.5 -
运行在以下环境
应用 awstats awstats 6.5_1 -
运行在以下环境
应用 awstats awstats 6.5_1.857 -
运行在以下环境
应用 awstats awstats 6.6 -
运行在以下环境
应用 awstats awstats 6.7 -
运行在以下环境
应用 awstats awstats 6.8 -
运行在以下环境
应用 awstats awstats 6.9 -
CVSS3评分
7.5
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    N/A
  • 用户交互
  • 可用性
    部分地
  • 保密性
    部分地
  • 完整性
    部分地
CWE-ID 漏洞类型
CWE-94 对生成代码的控制不恰当(代码注入)
阿里云安全产品覆盖情况