中危 PolicyKit "pkexec"竞争条件特权提升漏洞

CVE编号

CVE-2011-1485

利用情况

暂无

补丁情况

官方补丁

披露时间

2011-06-01
漏洞描述
PolicyKit是一组应用程序级别的API,用来定义和处理让无特权的进程(即非root用户启动的进程)来处理一些特权的任务。当检测父进程权限时存在一个竞争条件错误,调用父进程的suid root应用程序可提升特权,可能获得root特权。
解决建议
用户可参考如下供应商提供的安全公告获得补丁信息:http://cgit.freedesktop.org/PolicyKit/commit/?id=dd848a42a64a3b22a0cc60f6657b56ce9b6010aehttp://cgit.freedesktop.org/PolicyKit/commit/?id=129b6223a19e7fb2753f8cad7957ac5402394076 http://cgit.freedesktop.org/PolicyKit/commit/?id=c23d74447c7615dc74dae259f0fc3688ec988867 http://cgit.freedesktop.org/PolicyKit/commit/?id=3b12cfac29dddd27f1f166a7574d8374cc1dccf2
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat policykit 0.96 -
运行在以下环境
系统 debian_6 policykit-1 * Up to
(excluding)
0.96-4+squeeze1
运行在以下环境
系统 oracle_6 policykit-1 * Up to
(excluding)
0.96-2.el6_0.1
运行在以下环境
系统 redhat_6 polkit * Up to
(excluding)
0:0.96-2.el6_0.1
运行在以下环境
系统 suse_12 libpolkit0-32bit * Up to
(excluding)
0.112-2
阿里云评分
4.1
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-362 使用共享资源的并发执行不恰当同步问题(竞争条件)
阿里云安全产品覆盖情况