低危 Cyrus IMAPd 远程认证绕过漏洞

CVE编号

CVE-2011-3372

利用情况

暂无

补丁情况

没有补丁

披露时间

2011-12-25
漏洞描述
Cyrus IMAPD是一款免费开放源代码IMAP协议实现,可使用在Unix和Linux操作系统下。Cyrus IMAPd 2.4.10和2.4.11及其他版本中存在远程认证绕过漏洞。攻击者可利用该漏洞绕过认证进程,并通过发送没有AUTHINFO PASS的AUTHINFO USER命令执行任意命令。<br>
解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
http://cyrusimap.org/mediawiki/index.php/Latest_Updates
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 cyrus imapd * Up to
(including)
2.4.11
运行在以下环境
系统 amazon_AMI cyrus-imapd * Up to
(excluding)
2.3.16-6.5.amzn1
运行在以下环境
系统 centos_5 cyrus-imapd * Up to
(excluding)
2.3.7-12.el5_7.2
运行在以下环境
系统 oracle_5 cyrus-imapd * Up to
(excluding)
2.3.7-12.0.1.el5_7.2
运行在以下环境
系统 oracle_6 cyrus-imapd * Up to
(excluding)
2.3.7-12.0.1.el5_7.2
运行在以下环境
系统 redhat_6 cyrus-imapd * Up to
(excluding)
0:2.2.12-17.el4
运行在以下环境
系统 suse_12 perl-Cyrus-IMAP * Up to
(excluding)
2.3.18-35
运行在以下环境
系统 ubuntu_12.04.5_lts cyrus-imapd-2.4 * Up to
(excluding)
2.4.12-2
运行在以下环境
系统 ubuntu_12.04_lts cyrus-imapd-2.4 * Up to
(excluding)
2.4.12-2
运行在以下环境
系统 ubuntu_14.04.6_lts cyrus-imapd-2.4 * Up to
(excluding)
2.4.16-1
运行在以下环境
系统 ubuntu_14.04_lts cyrus-imapd-2.4 * Up to
(excluding)
2.4.16-1
运行在以下环境
系统 ubuntu_16.04.7_lts cyrus-imapd-2.4 * Up to
(excluding)
2.4.16-1
运行在以下环境
系统 ubuntu_16.04_lts cyrus-imapd-2.4 * Up to
(excluding)
2.4.16-1
阿里云评分
3.8
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    没有补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-287 认证机制不恰当
阿里云安全产品覆盖情况