低危 apt Verify-Host配置签名校验漏洞

CVE编号

CVE-2011-3634

利用情况

暂无

补丁情况

官方补丁

披露时间

2014-03-01
漏洞描述
Debian apt是一款包管理工具。Debian apt没有正确遵循Verify-Host配置选项,当不匹配x509证书主机名时,远程攻击者可以提供特制的APT库URL,并诱使本地用户使用,可成功导致MITM攻击。
解决建议
用户可参考如下供应商提供的安全公告获得补丁信息:http://bazaar.launchpad.net/~donkult/apt/sid/revision/2053.1.28
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 debian advanced_package_tool * Up to
(including)
0.8.10.3
运行在以下环境
应用 debian advanced_package_tool 0.8.0 -
运行在以下环境
应用 debian advanced_package_tool 0.8.1 -
运行在以下环境
应用 debian advanced_package_tool 0.8.10 -
运行在以下环境
应用 debian advanced_package_tool 0.8.10.1 -
运行在以下环境
应用 debian advanced_package_tool 0.8.10.2 -
运行在以下环境
系统 debian_6 apt * Up to
(excluding)
0.8.10.3+squeeze2
阿里云评分
2.3
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    -
CWE-ID 漏洞类型
CWE-200 信息暴露
阿里云安全产品覆盖情况