低危 ISC BIND up to 9.8.x Recursive Query Processor 拒绝服务漏洞

CVE编号

CVE-2011-4313

利用情况

暂无

补丁情况

官方补丁

披露时间

2011-11-30
漏洞描述
ISC BIND是一款DNS协议的实现。ISC BIND存在安全漏洞,由于目前还未知的原因,使用BIND 9软件的递归服务器会缓存一个无效记录,随后收到客户端对这一记录的查询时会在缓存中查找到这一记录并应答。受漏洞影响的BIND9递归服务器应答时会在记录query.c错误信息:"INSIST(! dns_rdataset_isassociated(sigrdataset))"之后发生崩溃,造成服务中断。
解决建议
用户可参考如下供应商提供的测试补丁:https://www.isc.org/software/bind/981-p1https://www.isc.org/software/bind/974-p1https://www.isc.org/software/bind/96-esv-r5-p1https://www.isc.org/software/bind/94-esv-r5-p1
参考链接
http://blogs.oracle.com/sunsecurity/entry/cve_2011_4313_denial_of
http://lists.apple.com/archives/security-announce/2012/Sep/msg00004.html
http://lists.fedoraproject.org/pipermail/package-announce/2011-November/069463.html
http://lists.fedoraproject.org/pipermail/package-announce/2011-November/069970.html
http://lists.fedoraproject.org/pipermail/package-announce/2011-November/069975.html
http://lists.opensuse.org/opensuse-security-announce/2011-11/msg00027.html
http://lists.opensuse.org/opensuse-security-announce/2011-11/msg00028.html
http://lists.opensuse.org/opensuse-security-announce/2011-11/msg00029.html
http://marc.info/?l=bugtraq&m=132310123002302&w=2
http://marc.info/?l=bugtraq&m=133978480208466&w=2
http://marc.info/?l=bugtraq&m=141879471518471&w=2
http://osvdb.org/77159
http://secunia.com/advisories/46536
http://secunia.com/advisories/46829
http://secunia.com/advisories/46887
http://secunia.com/advisories/46890
http://secunia.com/advisories/46905
http://secunia.com/advisories/46906
http://secunia.com/advisories/46943
http://secunia.com/advisories/46984
http://secunia.com/advisories/47043
http://secunia.com/advisories/47075
http://secunia.com/advisories/48308
http://security.freebsd.org/advisories/FreeBSD-SA-11:06.bind.asc
http://support.apple.com/kb/HT5501
http://www-01.ibm.com/support/docview.wss?uid=isg1IV11106
http://www.debian.org/security/2011/dsa-2347
http://www.ibm.com/support/docview.wss?uid=isg1IV11248
http://www.isc.org/software/bind/advisories/cve-2011-4313
http://www.kb.cert.org/vuls/id/606539
http://www.mandriva.com/security/advisories?name=MDVSA-2011:176
http://www.redhat.com/support/errata/RHSA-2011-1458.html
http://www.redhat.com/support/errata/RHSA-2011-1459.html
http://www.redhat.com/support/errata/RHSA-2011-1496.html
http://www.securityfocus.com/bid/50690
http://www.securitytracker.com/id?1026335
http://www.ubuntu.com/usn/USN-1264-1
https://exchange.xforce.ibmcloud.com/vulnerabilities/71332
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.ova...
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 isc bind 9.0 -
运行在以下环境
应用 isc bind 9.0.0 -
运行在以下环境
应用 isc bind 9.0.1 -
运行在以下环境
应用 isc bind 9.1 -
运行在以下环境
应用 isc bind 9.1.0 -
运行在以下环境
应用 isc bind 9.1.1 -
运行在以下环境
应用 isc bind 9.1.2 -
运行在以下环境
应用 isc bind 9.1.3 -
运行在以下环境
应用 isc bind 9.2.0 -
运行在以下环境
应用 isc bind 9.2.1 -
运行在以下环境
应用 isc bind 9.2.2 -
运行在以下环境
应用 isc bind 9.2.3 -
运行在以下环境
应用 isc bind 9.2.4 -
运行在以下环境
应用 isc bind 9.2.5 -
运行在以下环境
应用 isc bind 9.2.6 -
运行在以下环境
应用 isc bind 9.2.7 -
运行在以下环境
应用 isc bind 9.2.8 -
运行在以下环境
应用 isc bind 9.2.9 -
运行在以下环境
应用 isc bind 9.3 -
运行在以下环境
应用 isc bind 9.3.0 -
运行在以下环境
应用 isc bind 9.3.1 -
运行在以下环境
应用 isc bind 9.3.2 -
运行在以下环境
应用 isc bind 9.3.3 -
运行在以下环境
应用 isc bind 9.3.4 -
运行在以下环境
应用 isc bind 9.3.5 -
运行在以下环境
应用 isc bind 9.3.6 -
运行在以下环境
应用 isc bind 9.4 -
运行在以下环境
应用 isc bind 9.4.0 -
运行在以下环境
应用 isc bind 9.4.1 -
运行在以下环境
应用 isc bind 9.4.2 -
运行在以下环境
应用 isc bind 9.4.3 -
运行在以下环境
应用 isc bind 9.5 -
运行在以下环境
应用 isc bind 9.5.0 -
运行在以下环境
应用 isc bind 9.5.1 -
运行在以下环境
应用 isc bind 9.5.2 -
运行在以下环境
应用 isc bind 9.5.3 -
运行在以下环境
应用 isc bind 9.6 -
运行在以下环境
应用 isc bind 9.6.0 -
运行在以下环境
应用 isc bind 9.6.1 -
运行在以下环境
应用 isc bind 9.6.2 -
运行在以下环境
应用 isc bind 9.6.3 -
运行在以下环境
应用 isc bind 9.7.0 -
运行在以下环境
应用 isc bind 9.7.1 -
运行在以下环境
应用 isc bind 9.7.2 -
运行在以下环境
应用 isc bind 9.7.3 -
运行在以下环境
应用 isc bind 9.7.4 -
运行在以下环境
应用 isc bind 9.8.0 -
运行在以下环境
应用 isc bind 9.8.1 -
运行在以下环境
应用 isc bind 9.9.0 -
运行在以下环境
系统 redhat_5 bind97 * Up to
(excluding)
32:9.7.0-6.P2.el5_7.4
运行在以下环境
系统 redhat_6 bind * Up to
(excluding)
32:9.7.3-2.el6_1.P3.3
运行在以下环境
系统 suse_12 bind * Up to
(excluding)
9.9.5P1-1
阿里云评分
3.4
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况