nginx 'location'受限资源访问漏洞

CVE编号

CVE-2011-4963

利用情况

暂无

补丁情况

N/A

披露时间

2012-07-27
漏洞描述
nginx是一款高性能的web服务器,使用非常广泛,其不仅经常被用作反向代理,也可以非常好的支持PHP的运行。在处理"location"指令定义资源的HTTP请求时存在一个错误。可被利用攻击者利用通过构建特制的包含NTFS扩展属性的HTTP请求来访问受限资源。
解决建议
nginx 1.2.1已经修复此漏洞,建议用户下载使用:http://www.nginx.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 nginx nginx * From
(including)
0.7.52
Up to
(excluding)
1.2.1
运行在以下环境
应用 nginx nginx 1.3.0 -
CVSS3评分
5.0
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    N/A
  • 用户交互
  • 可用性
  • 保密性
    部分地
  • 完整性
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况