低危 Augeas信息泄露任意文件覆盖

CVE编号

CVE-2012-0787

利用情况

暂无

补丁情况

官方补丁

披露时间

2013-11-24 07:55:00
漏洞描述
在1.0.0之前的Augeas中transfer.c中的clone_file函数,当设置了copy_if_rename_fails并且重命名函数返回EXDEV或EBUSY时,允许本地用户通过(1)augsave或(2)使用备份保存选项时的目标文件,(3)或使用newfile保存选项时的.augnew文件上的绑定挂载覆盖任意文件并获取敏感信息。

解决建议
目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
http://augeas.net/news.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 augeas augeas * Up to
(including)
0.10.0
运行在以下环境
应用 augeas augeas 0.0.1 -
运行在以下环境
应用 augeas augeas 0.0.2 -
运行在以下环境
应用 augeas augeas 0.0.3 -
运行在以下环境
应用 augeas augeas 0.0.4 -
运行在以下环境
应用 augeas augeas 0.0.5 -
运行在以下环境
应用 augeas augeas 0.0.6 -
运行在以下环境
应用 augeas augeas 0.0.7 -
运行在以下环境
应用 augeas augeas 0.0.8 -
运行在以下环境
应用 augeas augeas 0.1.0 -
运行在以下环境
应用 augeas augeas 0.1.1 -
运行在以下环境
应用 augeas augeas 0.2.0 -
运行在以下环境
应用 augeas augeas 0.2.1 -
运行在以下环境
应用 augeas augeas 0.2.2 -
运行在以下环境
应用 augeas augeas 0.3.0 -
运行在以下环境
应用 augeas augeas 0.3.1 -
运行在以下环境
应用 augeas augeas 0.3.2 -
运行在以下环境
应用 augeas augeas 0.3.3 -
运行在以下环境
应用 augeas augeas 0.3.4 -
运行在以下环境
应用 augeas augeas 0.3.5 -
运行在以下环境
应用 augeas augeas 0.3.6 -
运行在以下环境
应用 augeas augeas 0.4.0 -
运行在以下环境
应用 augeas augeas 0.4.1 -
运行在以下环境
应用 augeas augeas 0.4.2 -
运行在以下环境
应用 augeas augeas 0.5.0 -
运行在以下环境
应用 augeas augeas 0.5.1 -
运行在以下环境
应用 augeas augeas 0.5.2 -
运行在以下环境
应用 augeas augeas 0.5.3 -
运行在以下环境
应用 augeas augeas 0.6.0 -
运行在以下环境
应用 augeas augeas 0.7.0 -
运行在以下环境
应用 augeas augeas 0.7.1 -
运行在以下环境
应用 augeas augeas 0.7.2 -
运行在以下环境
应用 augeas augeas 0.7.3 -
运行在以下环境
应用 augeas augeas 0.7.4 -
运行在以下环境
应用 augeas augeas 0.8.0 -
运行在以下环境
应用 augeas augeas 0.8.1 -
运行在以下环境
应用 augeas augeas 0.9.0 -
运行在以下环境
系统 amazon linux_AMI augeas * Up to
(excluding)
1.0.0-5.5.amzn1
运行在以下环境
系统 amazon_AMI augeas * Up to
(excluding)
1.0.0-5.5.amzn1
运行在以下环境
系统 debian_6 augeas * Up to
(excluding)
0.7.2-1+deb6u1
运行在以下环境
系统 oracle linux_6 augeas * Up to
(excluding)
1.0.0-5.el6
运行在以下环境
系统 oracle_6 augeas * Up to
(excluding)
1.0.0-5.el6
运行在以下环境
系统 redhat enterprise_linux 6.0 -
运行在以下环境
系统 redhat_6 augeas * Up to
(excluding)
0:1.0.0-5.el6
运行在以下环境
系统 ubuntu_14.04_lts augeas * Up to
(excluding)
1.0.0-1
运行在以下环境
系统 ubuntu_16.04_lts augeas * Up to
(excluding)
1.0.0-1
阿里云评分
3.0
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况