中危 Apache Portable Runtime up to 1.4.3 拒绝服务漏洞

CVE编号

CVE-2012-0840

利用情况

暂无

补丁情况

官方补丁

披露时间

2012-02-11
漏洞描述
Apache APR-util是一款可移植运行库,全名为Apache Portable Runtime。当哈希表单POST和更新哈希表时哈希生成函数存在错误,远程攻击者可以利用漏洞构建特制的表单,提交HTTP POST请求触发哈希碰撞,消耗系统大量CPU资源而导致拒绝服务攻击。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache portable_runtime * Up to
(including)
1.4.5
运行在以下环境
应用 apache portable_runtime 0.9.1 -
运行在以下环境
应用 apache portable_runtime 0.9.16-dev -
运行在以下环境
应用 apache portable_runtime 0.9.2 -
运行在以下环境
应用 apache portable_runtime 0.9.2-dev -
运行在以下环境
应用 apache portable_runtime 0.9.3 -
运行在以下环境
应用 apache portable_runtime 0.9.3-dev -
运行在以下环境
应用 apache portable_runtime 0.9.4 -
运行在以下环境
应用 apache portable_runtime 0.9.5 -
运行在以下环境
应用 apache portable_runtime 0.9.6 -
运行在以下环境
应用 apache portable_runtime 0.9.7 -
运行在以下环境
应用 apache portable_runtime 0.9.7-dev -
运行在以下环境
应用 apache portable_runtime 0.9.8 -
运行在以下环境
应用 apache portable_runtime 0.9.9 -
运行在以下环境
应用 apache portable_runtime 1.3.0 -
运行在以下环境
应用 apache portable_runtime 1.3.1 -
运行在以下环境
应用 apache portable_runtime 1.3.10 -
运行在以下环境
应用 apache portable_runtime 1.3.11 -
运行在以下环境
应用 apache portable_runtime 1.3.12 -
运行在以下环境
应用 apache portable_runtime 1.3.13 -
运行在以下环境
应用 apache portable_runtime 1.3.2 -
运行在以下环境
应用 apache portable_runtime 1.3.3 -
运行在以下环境
应用 apache portable_runtime 1.3.4 -
运行在以下环境
应用 apache portable_runtime 1.3.4-dev -
运行在以下环境
应用 apache portable_runtime 1.3.5 -
运行在以下环境
应用 apache portable_runtime 1.3.6 -
运行在以下环境
应用 apache portable_runtime 1.3.6-dev -
运行在以下环境
应用 apache portable_runtime 1.3.7 -
运行在以下环境
应用 apache portable_runtime 1.3.8 -
运行在以下环境
应用 apache portable_runtime 1.3.9 -
运行在以下环境
应用 apache portable_runtime 1.4.0 -
运行在以下环境
应用 apache portable_runtime 1.4.1 -
运行在以下环境
应用 apache portable_runtime 1.4.2 -
运行在以下环境
应用 apache portable_runtime 1.4.3 -
运行在以下环境
应用 apache portable_runtime 1.4.4 -
运行在以下环境
系统 ubuntu_12.04.5_lts apr * Up to
(excluding)
1.4.6-1
运行在以下环境
系统 ubuntu_12.04_lts apr * Up to
(excluding)
1.4.6-1
运行在以下环境
系统 ubuntu_14.04.6_lts apr * Up to
(excluding)
1.4.6-1
运行在以下环境
系统 ubuntu_14.04_lts apr * Up to
(excluding)
1.4.6-1
阿里云评分
6.5
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况