中危 nginx 'ngx_http_mp4_module.c'缓冲区溢出漏洞

CVE编号

CVE-2012-2089

利用情况

暂无

补丁情况

官方补丁

披露时间

2012-04-18
漏洞描述
nginx是一款高性能的web服务器,使用非常广泛,其不仅经常被用作反向代理,也可以非常好的支持PHP的运行。nginx标准MP4 pseudo-streaming(伪流)模块存在缺陷,如果使用了ngx_http_mp4_module特制的MP4文件可覆盖worker进程的内存。这可导致以nginx用户上下文执行任意代码。
解决建议
用户可参考如下供应商提供安全公告获得补丁信息:http://nginx.org/download/patch.2012.mp4.txt
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 nginx nginx * From
(including)
1.0.7
Up to
(including)
1.0.14
运行在以下环境
应用 nginx nginx * From
(including)
1.1.3
Up to
(including)
1.1.18
运行在以下环境
系统 amazon_AMI nginx * Up to
(excluding)
1.0.15-1.9.amzn1
运行在以下环境
系统 fedora_EPEL_6 nginx * Up to
(excluding)
1.0.15-1.el6
阿里云评分
5.3
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-120 未进行输入大小检查的缓冲区拷贝(传统缓冲区溢出)
阿里云安全产品覆盖情况