低危 Apache Commons-compress 1.0/1.1/1.2/1.3/1.4 拒绝服务漏洞

CVE编号

CVE-2012-2098

利用情况

暂无

补丁情况

官方补丁

披露时间

2012-06-30 08:55:00
漏洞描述
Apache Commons Compress用以实现将文件压缩或解压成tar、zip、bzip2等格式。Apache Ant是一个将软件编译、测试、部署等步骤联系在一起加以自动化的一个工具,用于Java环境中的软件开发。当使用bzip2进行文件压缩时存在一个错误,向BZip2CompressorOutputStream类提交特制文件可消耗大量系统资源,造成拒绝服务攻击。Apache Ant绑定的Apache Commons Compress库也受此漏洞影响。
解决建议
Apache Software Foundation Commons Compress 1.4.1和Apache Software Foundation Ant 1.8.4已经修复此漏洞,建议用户下载使用:http://www.ibm.com/support/docview.wss?uid=swg21596191
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache commons-compress * Up to
(including)
1.4
运行在以下环境
应用 apache commons-compress 1.0 -
运行在以下环境
应用 apache commons-compress 1.1 -
运行在以下环境
应用 apache commons-compress 1.2 -
运行在以下环境
应用 apache commons-compress 1.3 -
运行在以下环境
系统 suse_11 ant * Up to
(excluding)
1.7.1-20.9
运行在以下环境
系统 ubuntu_14.04_lts libcommons-compress-java * Up to
(excluding)
1.4.1-1
运行在以下环境
系统 ubuntu_16.04_lts libcommons-compress-java * Up to
(excluding)
1.4.1-1
阿里云评分
3.5
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
阿里云安全产品覆盖情况