低危 OpenSSL编码ASN.1数据不完整修补内存破坏漏洞(CNVD-2012-2152)

CVE编号

CVE-2012-2131

利用情况

暂无

补丁情况

官方补丁

披露时间

2012-04-25
漏洞描述
OpenSSL是一款开放源码的SSL实现,用来实现网络通信的高强度加密。发现针对OpenSSL CVE-2012-2110安全漏洞修复没有正确完全的应用于OpenSSL 0.9.x版本。不完全修复问题不影响1.0.0和1.0.1版本,仅影响OpenSSL 0.9.8v。
解决建议
OpenSSL Project OpenSSL 0.9.8w已经修复此漏洞,建议用户下载使用:http://www.openssl.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 openssl openssl 0.9.8v -
运行在以下环境
系统 debian_6 openssl * Up to
(excluding)
0.9.8o-4squeeze12
阿里云评分
3.5
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-189 数值错误
阿里云安全产品覆盖情况