低危 Net-SNMP 5.7.1 handle_nsExtendOutput2Table 拒绝服务漏洞

CVE编号

CVE-2012-2141

利用情况

暂无

补丁情况

官方补丁

披露时间

2012-08-15
漏洞描述
Net-SNMP是一款免费的、开放源码的SNMP实现,以前称为UCD-SNMP。Net-SNMP存在安全漏洞,允许恶意用户进行拒绝服务攻击。当处理某些MIB子树时"handle_nsExtendOutput2Table()"函数(agent/mibgroup/agent/extend.c)存在数组索引错误,攻击者提交特制的SNMP GET请求可导致"snmpd"进程崩溃。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 net-snmp net-snmp 5.7.1 -
运行在以下环境
系统 amazon_AMI net-snmp * Up to
(excluding)
5.5-41.10.amzn1
运行在以下环境
系统 centos_5 net-snmp * Up to
(excluding)
5.3.2.2-20.el5
运行在以下环境
系统 centos_6 net-snmp * Up to
(excluding)
5.5-41.el6
运行在以下环境
系统 debian_6 net-snmp * Up to
(excluding)
5.4.3~dfsg-2+squeeze1
运行在以下环境
系统 oracle_5 net-snmp * Up to
(excluding)
5.3.2.2-20.0.2.el5
运行在以下环境
系统 oracle_6 net-snmp * Up to
(excluding)
5.5-41.el6
运行在以下环境
系统 redhat_5 net-snmp * Up to
(excluding)
1:5.3.2.2-20.el5
运行在以下环境
系统 redhat_6 net-snmp * Up to
(excluding)
1:5.5-41.el6
运行在以下环境
系统 suse_12 libsnmp30 * Up to
(excluding)
5.7.3-6.6
运行在以下环境
系统 ubuntu_12.04.5_lts net-snmp * Up to
(excluding)
5.4.3~dfsg-2.4ubuntu1.1
阿里云评分
3.2
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况