低危 OpenOffice.org PPT文档拒绝服务漏洞

CVE编号

CVE-2012-2334

利用情况

暂无

补丁情况

官方补丁

披露时间

2012-06-20
漏洞描述
OpenOffice是一款开放源代码的文字处理系统。OpenOffice存在漏洞。由于filter/source/msfilter msdffimp.cxx未能检查内存分配,通过畸形Powerpoint图像记录("escher")可导致bad_alloc异常,可造成应用程序崩溃。
解决建议
OpenOffice 3.4已经修复此漏洞,建议用户下载使用:http://www.openoffice.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache openoffice.org 3.3 -
运行在以下环境
应用 apache openoffice.org 3.4 -
运行在以下环境
应用 libreoffice libreoffice * Up to
(including)
3.5.2
运行在以下环境
应用 libreoffice libreoffice 3.3.0 -
运行在以下环境
应用 libreoffice libreoffice 3.3.1 -
运行在以下环境
应用 libreoffice libreoffice 3.3.2 -
运行在以下环境
应用 libreoffice libreoffice 3.3.3 -
运行在以下环境
应用 libreoffice libreoffice 3.3.4 -
运行在以下环境
应用 libreoffice libreoffice 3.4.0 -
运行在以下环境
应用 libreoffice libreoffice 3.4.1 -
运行在以下环境
应用 libreoffice libreoffice 3.4.2 -
运行在以下环境
应用 libreoffice libreoffice 3.4.5 -
运行在以下环境
应用 libreoffice libreoffice 3.5 -
运行在以下环境
系统 centos_6 openoffice.org * Up to
(excluding)
3.2.1-19.6.el6_2.7
运行在以下环境
系统 debian_6 openoffice.org * Up to
(excluding)
1:3.2.1-11+squeeze6
运行在以下环境
系统 oracle_6 openoffice.org * Up to
(excluding)
3.2.1-19.6.0.1.el6_2.7
运行在以下环境
系统 redhat_6 autocorr-af * Up to
(excluding)
1:3.2.1-19.6.el6_2.7
运行在以下环境
系统 suse_10 libreoffice-cs * Up to
(excluding)
3.4.5.5-0.7.1
运行在以下环境
系统 ubuntu_12.04.5_lts libreoffice * Up to
(excluding)
1:3.5.3-0ubuntu1
阿里云评分
3.5
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-189 数值错误
阿里云安全产品覆盖情况