低危 GNU Bash栈缓冲区溢出漏洞

CVE编号

CVE-2012-3410

利用情况

暂无

补丁情况

官方补丁

披露时间

2012-08-28 12:55:00
漏洞描述
GNU Bash是一款操作系统使用的SHELL。当检查文件名('test' command)和在条件命令表达式中对/dev/fd文件名求值时, GNU Bash扩展部分/dev/fd文件名存在一个基于栈的缓冲区溢出缺陷。远程攻击者可以提供特制的Bash脚本,诱使应用程序解析,可使bash执行程序崩溃。
解决建议
用户可参考如下供应商提供的安全公告获得补丁信息:ftp://ftp.gnu.org/pub/gnu/bash/bash-4.2-patches/bash42-033
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu bash 4.2 -
运行在以下环境
系统 suse_11 bash * Up to
(excluding)
3.2-147.12
运行在以下环境
系统 ubuntu_14.04_lts bash * Up to
(excluding)
4.2-4ubuntu1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况