Endian Firewall 2.4 dnat.cgi addrule 跨站脚本攻击

CVE编号

CVE-2012-4923

利用情况

暂无

补丁情况

N/A

披露时间

2012-09-16
漏洞描述
Endian Firewall是开源的防火墙设备。 Endian Firewall 2.4存在多个XSS漏洞,可允许远程攻击者通过createrule参数向dnat.cgi传参、addrule参数向dansguardian.cgi传参、 PATH_INFO参数向openvpn_users.cgi传参,注入任意Web脚本或HTML。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 endian firewall 2.4 -
CVSS3评分
4.3
  • 攻击路径
    网络
  • 攻击复杂度
    N/A
  • 权限要求
  • 影响范围
    N/A
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
    部分地
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况