低危 Apache CouchDB远程代码执行漏洞

CVE编号

CVE-2012-5649

利用情况

暂无

补丁情况

官方补丁

披露时间

2014-05-24
漏洞描述
CouchDB是一款用Erlang开发的面向文档的数据库系统。Apache CouchDB支持JSONP但默认禁用,拥有管理员权限可启用JSONP,特制的JSONP回调和应答可用于在客户端浏览器中通过Adobe Flash执行任意代码。
解决建议
Apache CouchDB 1.0.4, 1.1.2或1.2.1已经修复此漏洞,建议用户下载使用:http://couchdb.apache.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache couchdb * Up to
(including)
1.0.3
运行在以下环境
应用 apache couchdb 1.0.0 -
运行在以下环境
应用 apache couchdb 1.0.1 -
运行在以下环境
应用 apache couchdb 1.0.2 -
运行在以下环境
应用 apache couchdb 1.1.0 -
运行在以下环境
应用 apache couchdb 1.1.1 -
运行在以下环境
应用 apache couchdb 1.2.0 -
运行在以下环境
系统 fedora_EPEL_5 couchdb * Up to
(excluding)
1.0.4-2.el5.1
运行在以下环境
系统 fedora_EPEL_5 couchdb-debuginfo * Up to
(excluding)
1.0.4-2.el5.1
运行在以下环境
系统 fedora_EPEL_6 couchdb * Up to
(excluding)
1.0.4-2.el6
运行在以下环境
系统 fedora_EPEL_6 couchdb-debuginfo * Up to
(excluding)
1.0.4-2.el6
阿里云评分
3.3
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-94 对生成代码的控制不恰当(代码注入)
阿里云安全产品覆盖情况