低危 Apache Axis2证书校验中间人攻击漏洞(CNVD-2012-6308)

CVE编号

CVE-2012-5784

利用情况

暂无

补丁情况

官方补丁

披露时间

2012-11-05
漏洞描述
Apache Axis2是Apache web services/SOAP/WDSL引擎,它是Apache SOAP项目的延续。PayPal Payments Pro, PayPal Mass Pay, PayPal Transactional Information SOAP和Apache ActiveMQ Java Message Service实现使用的Apache Axis没有正确校验主机名是否与CN中的域名或X.509证书subjectAltName字段的域名匹配,允许攻击者通过任意合法证书进行中间人攻击,欺骗SSL服务器。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache activemq * Up to
(including)
5.7.0
运行在以下环境
应用 apache axis * Up to
(including)
1.4
运行在以下环境
应用 apache axis - -
运行在以下环境
应用 apache axis 1.0 -
运行在以下环境
应用 apache axis 1.1 -
运行在以下环境
应用 apache axis 1.2 -
运行在以下环境
应用 apache axis 1.2.1 -
运行在以下环境
应用 apache axis 1.3 -
运行在以下环境
应用 paypal mass_pay - -
运行在以下环境
应用 paypal payments_pro - -
运行在以下环境
应用 paypal transactional_information_soap - -
运行在以下环境
系统 amazon_AMI axis * Up to
(excluding)
1.2.1-7.3.11.amzn1
运行在以下环境
系统 centos_5 axis * Up to
(excluding)
1.2.1-2jpp.7.el5_9
运行在以下环境
系统 debian_6 axis * Up to
(excluding)
1.4-12+deb6u1
运行在以下环境
系统 opensuse_Leap_15.0 axis * Up to
(excluding)
1.4-lp150.9.1
运行在以下环境
系统 opensuse_Leap_42.3 axis * Up to
(excluding)
1.4-300.1
运行在以下环境
系统 oracle_5 axis * Up to
(excluding)
1.2.1-2jpp.7.el5_9
运行在以下环境
系统 oracle_6 axis * Up to
(excluding)
1.2.1-7.3.el6_3
运行在以下环境
系统 suse_12_SP3 axis * Up to
(excluding)
1.4-290.6.1
运行在以下环境
系统 suse_12_SP4 axis * Up to
(excluding)
1.4-290.6.1
阿里云评分
3.3
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况