低危 nokogiri nokogiri dtd中递归实体索引的不恰当限制(xml实体扩展)

CVE编号

CVE-2012-6685

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-02-20
漏洞描述
Apple iOS和OS X都是美国苹果(Apple)公司的操作系统。Apple iOS是为移动设备所开发;OS X是为Mac计算机所开发。
Apple iOS 8.4.1之前版本和OS X 10.10.5之前版本中存在安全漏洞。攻击者可利用该漏洞获取敏感信息,以系统权限执行任意代码,执行未授权操作,绕过安全限制,造成拒绝服务。
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
https://support.apple.com/en-us/HT205031
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 nokogiri nokogiri * Up to
(excluding)
1.5.4
运行在以下环境
应用 redhat cloudforms_management_engine 5.0 -
运行在以下环境
应用 redhat enterprise_mrg 2.0 -
运行在以下环境
应用 redhat openshift 2.0 -
运行在以下环境
应用 redhat openstack 4.0 -
运行在以下环境
应用 redhat openstack 6.0 -
运行在以下环境
应用 redhat openstack_foreman - -
运行在以下环境
应用 redhat satellite 6.0 -
运行在以下环境
应用 redhat subscription_asset_manager - -
运行在以下环境
系统 debian_6 libnokogiri-ruby * Up to
(excluding)
1.4.0-4+deb6u1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-776 DTD中递归实体索引的不恰当限制(XML实体扩展)
阿里云安全产品覆盖情况