低危 Expat加密机制破坏漏洞

CVE编号

CVE-2012-6702

利用情况

暂无

补丁情况

官方补丁

披露时间

2016-06-17
漏洞描述
Expat是一个基于C语言的XML解析器库,它采用了一个面向流的解析器。

当程序在调用XML_SetHashSalt的解析器中使用或传递一个0种子时Expat中存在安全漏洞,允许远程攻击者可利用该漏洞破坏加密保护机制。
解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
https://sourceforge.net/p/expat/code_git/ci/07cc2fcacf81b32b2e06aa918df51756525240c0/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libexpat expat * Up to
(excluding)
2.2.0
运行在以下环境
系统 alpine_3.2 expat * Up to
(excluding)
2.2.0-r0
运行在以下环境
系统 alpine_3.3 expat * Up to
(excluding)
2.2.0-r0
运行在以下环境
系统 alpine_3.4 expat * Up to
(excluding)
2.2.0-r0
运行在以下环境
系统 debian_7 expat * Up to
(excluding)
2.1.0-1+deb7u4
运行在以下环境
系统 debian_8 expat * Up to
(excluding)
2.1.0-6+deb8u6
运行在以下环境
系统 fedora_22 expat * Up to
(excluding)
2.1.1-2.fc22
运行在以下环境
系统 fedora_23 expat * Up to
(excluding)
2.1.1-2.fc23
运行在以下环境
系统 fedora_24 expat * Up to
(excluding)
2.1.1-2.fc24
运行在以下环境
系统 opensuse_Leap_42.1 expat * Up to
(excluding)
2.1.0-19.1
运行在以下环境
系统 opensuse_Leap_42.2 expat * Up to
(excluding)
2.1.0-19.1
运行在以下环境
系统 suse_11_SP4 expat * Up to
(excluding)
2.0.1-88.41.1
运行在以下环境
系统 suse_12_SP1 expat * Up to
(excluding)
2.1.0-20.2
运行在以下环境
系统 suse_12_SP2 expat * Up to
(excluding)
2.1.0-20.2
运行在以下环境
系统 ubuntu_14.04 expat * Up to
(excluding)
2.1.0-4ubuntu1.3
运行在以下环境
系统 ubuntu_16.04 expat * Up to
(excluding)
2.1.0-7ubuntu0.16.04.2
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
阿里云安全产品覆盖情况