低危 Bash 缓冲区错误漏洞

CVE编号

CVE-2012-6711

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-06-19
漏洞描述
在4.3之前的GNU Bash中,如果通过echo内置函数打印宽字符(LC_CTYPE环境变量中设置的当前区域设置不支持),则会出现基于堆的缓冲区溢出。本地攻击者可以通过“echo-e”内置函数提供打印数据,利用此漏洞使脚本崩溃或以bash进程的权限执行代码。发生这种情况是因为lib/sh/strtrans.c中的ansicstr()错误地处理了u32cconv()。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu bash * From
(including)
4.2
Up to
(including)
4.3
运行在以下环境
系统 suse_12 bash * Up to
(excluding)
4.2-83.6
运行在以下环境
系统 ubuntu_14.04_lts bash * Up to
(excluding)
4.3.7ubuntu1.8
运行在以下环境
系统 ubuntu_16.04_lts bash * Up to
(excluding)
4.3-14ubuntu1.3
运行在以下环境
系统 ubuntu_18.04_lts bash * Up to
(excluding)
4.4.18-2ubuntu1.1
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况